1 radiator not working

Discussion in 'Plumbing and Central Heating' started by jaynemit61, 29 Sep 2006.

This topic originated from the How to page called Problems associated with radiators.

  1. jaynemit61

    Joined:
    29 Sep 2006
    Messages:
    3
    Thanks Received:
    0
    Location:
    Cambridgeshire
    Country:
    United Kingdom
    I have 1 radiator not working, I have bleed this and turned it up to the highest setting on the temp guage. Any ideas as to what is wrong. All other work fine.
     
  2. Moz

    Moz

    Joined:
    19 Jun 2005
    Messages:
    5,141
    Thanks Received:
    0
    Country:
    United Kingdom
    TRV needs replacing ...:)
     
  3. jaynemit61

    Joined:
    29 Sep 2006
    Messages:
    3
    Thanks Received:
    0
    Location:
    Cambridgeshire
    Country:
    United Kingdom
    what is a trv?
     
  4. gasmarkone

    Joined:
    30 Jan 2006
    Messages:
    334
    Thanks Received:
    0
    Location:
    Dorset
    Country:
    United Kingdom
    Sticking pin on the TRV [that valve you turned up!]. How handy are you? The repair could involve some WD40, pair of pliers or maybe just a [not too large] hammer!
     
  5. Moz

    Moz

    Joined:
    19 Jun 2005
    Messages:
    5,141
    Thanks Received:
    0
    Country:
    United Kingdom
    Thermostatic Radiator Valve ...
     
  6. gasmarkone

    Joined:
    30 Jan 2006
    Messages:
    334
    Thanks Received:
    0
    Location:
    Dorset
    Country:
    United Kingdom
    Or an easier option could involve a telephone, a cup of tea and a cheque book!!!! :LOL:
     
  7. jordsbabe

    Joined:
    9 Nov 2007
    Messages:
    19
    Thanks Received:
    0
    Location:
    West Midlands
    Country:
    United Kingdom
    I have the same problem all radiatiors work apart from one!!!! It was working fine last winter! So what do I do with the pliers WD40?
     
  8. gas4you

    Joined:
    23 Feb 2007
    Messages:
    17,944
    Thanks Received:
    858
    Location:
    Norfolk
    Country:
    United Kingdom
    Take the head off the trv and gently tap the pin with a hammer.
     
  9. jordsbabe

    Joined:
    9 Nov 2007
    Messages:
    19
    Thanks Received:
    0
    Location:
    West Midlands
    Country:
    United Kingdom
    Thanks Just one more question i can't seem to get the tvr off, does it screw off?
     
  10. jordsbabe

    Joined:
    9 Nov 2007
    Messages:
    19
    Thanks Received:
    0
    Location:
    West Midlands
    Country:
    United Kingdom
    got it off now i can't get it back on :eek:
     
  11. jordsbabe

    Joined:
    9 Nov 2007
    Messages:
    19
    Thanks Received:
    0
    Location:
    West Midlands
    Country:
    United Kingdom
    it's ok panic over i've got it lol! thank you so much for your help!
     
  12. hezekiah

    Joined:
    16 Jan 2010
    Messages:
    2
    Thanks Received:
    0
    Location:
    Manchester
    Country:
    United Kingdom
    I removed the TRV, and checked the pin, and it's spring operation is working fine. I removed the pin erronously, and the radiator began to warm up, but once I replaced the pin it cooled down again.

    Only one radiator doesn't work in the whole house (in my room!) and I can't work out what the problem is.
     
  13. ManxPlumber

    Joined:
    7 Dec 2009
    Messages:
    103
    Thanks Received:
    8
    Country:
    United Kingdom
    When the heating is on, are both tails feeding the rad hot, or just one?

    ...is the lockshield open at the other end of the rad?
     
  14. hezekiah

    Joined:
    16 Jan 2010
    Messages:
    2
    Thanks Received:
    0
    Location:
    Manchester
    Country:
    United Kingdom
    The lockshield is definitely on. Only the pipe attached to the lockshield is warm. Like I said, it got warmer when water was bursting out of the TRV end (I accidentally took the pin out, although replaced it successfully, and checked it functioned properly).
     
  15. gazzaman22

    Joined:
    30 Jun 2010
    Messages:
    1
    Thanks Received:
    0
    Country:
    United Kingdom
    Hi Guys, One rad wouldn't work for me. So i tried the suggested but broke the little metal pin end...so now i need a new one...what are these called and where would i get one?...B&Q?, while trying to fix it i broke the whole housing unit it sits in as well so i'm gonna need the whole valve that screw to rad :oops:
     

Share This Page