Ariston Microgenus 27 MFFI not working?

Discussion in 'Plumbing and Central Heating' started by aaron2891, 14 Jul 2011.

  1. aaron2891

    Joined:
    14 Jul 2011
    Messages:
    3
    Thanks Received:
    0
    Location:
    Surrey
    Country:
    United Kingdom
    When I woke this morning my boiler was not working. The pilot light is out and the pressure is at 0. I have tried the reset button but still no joy. We havent been using the heating recently (no need) only the hot water.

    Any ideas? I would like to try and fix this myself if possible?
     
  2. picasso

    Joined:
    8 Apr 2008
    Messages:
    6,116
    Thanks Received:
    1,328
    Location:
    Essex
    Country:
    United Kingdom
    It wont work without pressure, there are 2 valves under the boiler for filling the system.

    ps it doesnt have a pilot, its automatic ignition.
     
    • Thanks Thanks x 1
  3. aaron2891

    Joined:
    14 Jul 2011
    Messages:
    3
    Thanks Received:
    0
    Location:
    Surrey
    Country:
    United Kingdom
    Pressure up to just under 2 now but no automatic ignition when I turn on the water or heating. Any advice appreciated.
     
  4. picasso

    Joined:
    8 Apr 2008
    Messages:
    6,116
    Thanks Received:
    1,328
    Location:
    Essex
    Country:
    United Kingdom
    turn off the electricity to the boiler for 10 seconds and then turn back on .
     
    • Thanks Thanks x 1
  5. aaron2891

    Joined:
    14 Jul 2011
    Messages:
    3
    Thanks Received:
    0
    Location:
    Surrey
    Country:
    United Kingdom
    Followed your advice and all working now.

    Thanks for the help.
     

Share This Page