Ferroli Boiler No hot water

Discussion in 'Plumbing and Central Heating' started by CRS, 13 Feb 2013.

  1. CRS

    CRS

    Joined:
    13 Feb 2013
    Messages:
    4
    Thanks Received:
    0
    Country:
    United Kingdom
    Good evening folks,
    I have a Ferroli C24 combi LPG boiler, i have had to take it apart to clean the heat exchanger as there was no water flow, but there was CH water flow. once i put it back together i now have water flow but it's not hot unles the CH is going but then its only warm. i did take the HW senor off and i cleaned a white residue off that i thought was a residue from the copper pipe but now i am wondering if it was not a gel for the sensor. It may be a simple sensor replacement but before pay for the Ferroli spanish plumber to come and shrug his shoulders like he normally does i could do with some suggestions. the CH and the HW go into different sides of the heat exchanger and from what i can see there is no diverter valve if that helps
    Thanks for any help.
     
  2. ianmcd

    Joined:
    15 Aug 2010
    Messages:
    3,342
    Thanks Received:
    701
    Location:
    Lanarkshire
    Country:
    United Kingdom
    The white residue is heat sink paste it helps to transfer the heat to the sensor, wouldnt worry too much that you have cleaned it off it just wont be as accurate it wont damage anything
     
    • Thanks Thanks x 1
  3. CRS

    CRS

    Joined:
    13 Feb 2013
    Messages:
    4
    Thanks Received:
    0
    Country:
    United Kingdom
    Just an update,
    replaced flow switch and HW sensor and still no hot water, anyone any ideas?
    Thanks
     
  4. dcawkwell

    Joined:
    2 Nov 2010
    Messages:
    3,390
    Thanks Received:
    513
    Location:
    Humberside
    Country:
    United Kingdom
    Diverter valve assuming the boiler fires when you turn the tap it
    a diverter valve problem.
     
  5. ianmcd

    Joined:
    15 Aug 2010
    Messages:
    3,342
    Thanks Received:
    701
    Location:
    Lanarkshire
    Country:
    United Kingdom
    your boiler doesnt have a diverter valve, more information please, do you have central heating / does the boiler do anything when you run the tap , Fan run ? pump run ?
     
  6. CRS

    CRS

    Joined:
    13 Feb 2013
    Messages:
    4
    Thanks Received:
    0
    Country:
    United Kingdom
    Hi Ianmcd
    when the tap is running there is nothing from the boiler, no firing up or pump running just running water no error flashes coming from the boiler.
    the central heating works fine comes on and turns off when told to do so. i am able to get warm water when the central heating is on but i guess that will be because the the boiler is fired up for the heating, the heating does not stop once the HW tap is running.
    hope this helps.
    Cheers
     
  7. ianmcd

    Joined:
    15 Aug 2010
    Messages:
    3,342
    Thanks Received:
    701
    Location:
    Lanarkshire
    Country:
    United Kingdom
    its something to do with your flow switch, basically when your boiler is running on CH the pump takes the heat to the radiators, when you open up a HW tap the pump stops and the flame increases and the water that comes out of your tap runs through the main heat exchanger and picks up its heat, as the heating is working it is something to do with the DHW flow switch
     
  8. CRS

    CRS

    Joined:
    13 Feb 2013
    Messages:
    4
    Thanks Received:
    0
    Country:
    United Kingdom
    just to let you know ianmcd, i just wiggled the CH sensor and then turnde on the hot water and would you belive it the boiler fired up. the water is not as hot as i would like but its a start. cheers for help.
     

Share This Page