1. We are pleased to announce the 'Home Automation' forum. Click here to get involved!

ferroli f24 domi compact f37 flashing

Discussion in 'Plumbing and Central Heating' started by coopegas83, 21 Feb 2011.

  1. coopegas83

    Joined:
    30 Aug 2009
    Messages:
    21
    Thanks Received:
    0
    Location:
    Birmingham
    Country:
    United Kingdom
    hi guys install boiler about 2years ago, customer rang to say f37 flashing which is low water pressure i have reset boiler and away it went call back to say constantly having to reset boiler. i installed new pressure switch to eliminate and also water in system clean i am now unsure as to what i do next as it is still throwing up f37 :mad: any suggestions would be greatly appreciated
     
  2. compheat

    Joined:
    22 Nov 2005
    Messages:
    2,139
    Thanks Received:
    378
    Location:
    Lancashire
    Country:
    United Kingdom
    I had the same thing last week, boiler losing pressure but no sign of any leaks
    It was the secondary heat exchanger/recuporater which leaks internally and the water goes down the condense drain.

    Ferroli quoted me £285+vat making it £342 for the part.

    This boiler is a load of Cr#p
     
  3. ecowarrior

    Joined:
    21 May 2010
    Messages:
    9,913
    Thanks Received:
    2,795
    Location:
    Northamptonshire
    Country:
    United Kingdom
    Common fault mate do about 5-6 a year. they do come up on ebay but usually 2nd hand boilers are sold because of this issue. Same one fits all so that helps a bit
     
  4. coopegas83

    Joined:
    30 Aug 2009
    Messages:
    21
    Thanks Received:
    0
    Location:
    Birmingham
    Country:
    United Kingdom
    in this case the boiler isnt losing pressure the customer or myself have not had to top the boiler up at all
     
  5. ecowarrior

    Joined:
    21 May 2010
    Messages:
    9,913
    Thanks Received:
    2,795
    Location:
    Northamptonshire
    Country:
    United Kingdom
    Look at blocked press gauge. Whist drained down check expn vess. charge to 1 bar. There are no parameters to check press electronically. Give gauge good rodding & look inside pump housing where it fits (not easy if u have the one that comes out the back) This area does sludge up. If the switch is doing its thing at (I think .8bar) the gauge may b reading 1.5 and looking good when its not. So it looks OK at 1.5 but its really kicking out at just below .8 and kicking in at .9. but the gauge is moving from 1.5 - 1.6?
     

Share This Page