1. We are pleased to announce the 'Home Automation' forum. Click here to get involved!

Intermittent problem with Grant Vortex boiler

Discussion in 'Plumbing and Central Heating' started by mabdevon, 6 Mar 2010.

  1. mabdevon

    Joined:
    6 Mar 2010
    Messages:
    2
    Thanks Received:
    0
    Country:
    United Kingdom
    Help!!! Am feeling very fed up. We had a Grant Vortex oil-fired combi-condenser fitted just over 2 years ago. Needless to say it's now out of guarantee. Started getting problems with the pressure dropping frequently in the autumn, and our installer came to the conclusion that we were having to top it up too often. Then the heating started to fail to come on when it should, though the programmer seemed to be working ok. Phones Grant and technician was puzzled as an intermittent fault, but sent us pcb as he thought that the likely problem. Had that fitted end of December but in the two months since, heating and (sometimes) hot water failing - intermittently - to come on as set. Sometimes pressure 0.25 or below, sometimes still up at 1. Our engineer fitted a new programmer yesterday. All well this morning, but now the heating has failed to come on again this afternoon and I have discovered there's no hot water either. I'm really fed up - our last boiler lasted 20 years with no problems, and the one we have now was the top of the range, so it was a lot of expense, especially as we had to change the old pipework too. Has anyone any experience of solving similar problems??
     
  2. Boilerman2

    Joined:
    10 Jun 2009
    Messages:
    5,205
    Thanks Received:
    1,005
    Location:
    Suffolk
    Country:
    United Kingdom
    Firstly, it sounds like there is more than one problem, the pressure loss could be lack of air in expansion vessel, (when was the boiler last serviced?) the Auto Air Vents may be leaking, the Low water pressure Switch may be leaking from it's O ring. if the pressure falls to 0-25Bar the boiler will shut down on Low Water, indicated by an orange lamp on the control panel, to reset you have to re-fill the system to 1-00 bar, boiler should restart automatically.

    However if the pressure is normal and you have no heat, check the Circ pump in the front bottom right (under the plate heat exch) if it is running, the boiler is in Hot Water mode, there may be water being drawn off, or the Thermal store may not have reached temperature, however if after 10mins with no water draw, the unit is still in HW mode, check the Flow Switch and the Temperature PCB (not the one with the control dial) inside the control panel. the store pcb could be faulty ;)
     
    • Thanks Thanks x 1
  3. MANDATE

    Joined:
    6 Mar 2003
    Messages:
    2,307
    Thanks Received:
    130
    Location:
    Manchester
    Country:
    United Kingdom
    As I understand it, some combis have a 'pressure switch' so the boiler won't come on if the pressure is too low.
    The pressure needs to be set around 1 bar to 1.3 bar while cold, then with the heating on, the volume of water will increase as it gets hotter.
    The excess water goes into the expansion vessel, which should start being full of 'air' and pre charged to about 0.8 bar.
    As the water goes in the vessel and pushes against the diaphragm, it compresses the air and the pressure increases as the volume decreases.
    So the rise in pressure is about 1 bar.
    What may have happened which is not unusal, is that the vessel has lost some or all of its pre charge over time(like car tyres do).
    This means the vessel contains water before any expansion takes place, it means there is little or no air to compress, but the extra water has to go somewhere.
    When pressure reaches 3 bar the Pressure Relief Valve opens and discharges some water through the external discharge pipe.
    The pressure then drops to something around the 0.25 bar which means you have to top it up again to 1 or 1.3 bar.
    This will continue to happen until the excess water in the expansion vessel has been removed and the vessel re charged.
    .
    Of course if there are any leaks at valves or in pipe work, the pressure will reduce even without the heating being on.
    So for now set pressure to 1 bar cold and see what the rise in pressure is when hot and if you tie a plastic bag on the discharge pipe, you will be able to check if any water has come through the PRV
     
    • Thanks Thanks x 1
  4. djsarge1973

    Joined:
    8 Mar 2010
    Messages:
    52
    Thanks Received:
    8
    Location:
    Sussex
    Country:
    United Kingdom
    Where abouts are you I have all the grant manuals...& I will probably be able to help...you say the boiler is 2 years old...does it have the red l.e.d warning lights on the front (DHW pump, CH pump)etc, let me know
     
    • Thanks Thanks x 1
  5. mabdevon

    Joined:
    6 Mar 2010
    Messages:
    2
    Thanks Received:
    0
    Country:
    United Kingdom
    Thanks for your help. Our engineer says someone else local has a very similar problem. The fact that it comes and goes to suit itself is really annoying, and a pain as, needless to say, if an engineer calls it's behaving beautifully! A new part is on the way - I think it's to do with the flow switch. If it sorts the problem out, I will let you all know, for future reference.
     
  6. Boilerman2

    Joined:
    10 Jun 2009
    Messages:
    5,205
    Thanks Received:
    1,005
    Location:
    Suffolk
    Country:
    United Kingdom
    it will be the Flow switch, or the Store PCB for sure, flow switch on some 26's can stick in the housing, so file a whisker from the paddle with a file just to be sure ;)

    Grant Service agent
     
  7. mrmomids

    Joined:
    28 May 2010
    Messages:
    2
    Thanks Received:
    0
    Location:
    Lincolnshire
    Country:
    United Kingdom
    Interesting. Had mine installed in February and had similar problems. Pressure would remain fine for a week or so, then would drop to 0.25 bar or less. Fill it up and it would be fine again for a couple of weeks. Now we are having warmer weather, I haven't seen any pressure loss for the last 6-8 weeks.
    Same solution you reckon?
    Dave
     
  8. djsarge1973

    Joined:
    8 Mar 2010
    Messages:
    52
    Thanks Received:
    8
    Location:
    Sussex
    Country:
    United Kingdom
    Hey Dave..Is this a new installation or just a new boiler?, & I'll be in lincolnshire next week so if your not sure I can come & have a look, also if it was a boiler swap (1 in 1 out) was the old system gravity fed (small tank in loft) then swapped over to pressurised system?
     
  9. mrmomids

    Joined:
    28 May 2010
    Messages:
    2
    Thanks Received:
    0
    Location:
    Lincolnshire
    Country:
    United Kingdom
    Its a new boiler, last one packed in. Its now an outside boiler. So some new pipework was needed, but not much. Had the heating on last night and the pressure is still the same. Was wondering if it might be the expansion tank being a bit dodgy. If it was a leak in the heating pipes then surely it would loose pressure regardless of temperature.
     
  10. djsarge1973

    Joined:
    8 Mar 2010
    Messages:
    52
    Thanks Received:
    8
    Location:
    Sussex
    Country:
    United Kingdom
    Not nessecarily, if you have a pinhole leak when the water is colder it is denser so it may not leak out, as the water becomes hotter it is less denser & may escape from the pipe work, or could be leaking through the A.A.V (Automatic Air Valve) another little thing that may happen is as the pipework expands under heat it can also move a joint that isn't properly made, as I said am in Lincolnshire from Tomorrow (30th May) until Thursday 3rd June...so if you want me to come have a look just let me know
     
  11. boilergonbust

    Joined:
    20 Jul 2010
    Messages:
    3
    Thanks Received:
    1
    Location:
    Devon
    Country:
    United Kingdom
    Hi mabdevon, Unfortunately we have a grant vortex now 31/2 years old, been trouble all its life and has failed yet again. Your pressure problem sounds like a system leak, we had leaks from the auto valves on top of the boiler and now have leaks from the pressure sensor and the make up valve. check yours out. we have also found an intermittent fault on the off/on switch. you may think its on but no power is getting through.
     
  12. JamesH1972

    Joined:
    14 Dec 2010
    Messages:
    1
    Thanks Received:
    0
    Location:
    Cornwall
    Country:
    United Kingdom
    My grant boiler is suffering the same problem. Just coming up to 2 years old. and the heating or hot water wont come on when programmed. I have the Grant RF programmer, it indicates that it is transmitting the signal and you can see the red LED on the receiver light up. You can hear a relay click over and the boiler tries to fire up but the relay breaks straight away stopping the process from continuing.
    This keeps happening every time the programmer sends a signal and eventually leads to the relay constantly chattering. Had an engineer around who trying to get an answer from grant as to whether it is the pcb or rx unit.
    The boiler has now started to loose pressure aswell, it has always dropped slowly (over a few months) since it was installed, but now is low every few days. Still waiting for an engineer to come around to investigate this one. Can anyone shed anymore light on to this apart from what is already mentioned.

    On another note as my wife doesnt really get on with the grant programmer, If i had to change it due to the problem I was thinking of going for a different one all together, I would still want An RF device for both HW and Heating. I have seen some from Heatmiser, are they any good?
     
  13. boilergonbust

    Joined:
    20 Jul 2010
    Messages:
    3
    Thanks Received:
    1
    Location:
    Devon
    Country:
    United Kingdom
    Hi James,
    Can't help with the programmer prob. but bearing in mind the complexity of boilers I would not go wireless, I do not trust telemetry. There are enough issues with grant boilers without adding another.
    You must have a system/ boiler leak to be losing pressure. I have already posted our leaks from the auto valves and pressure sensor but since then we found another. The water make up valve (again a Grant part) was leaking. Since being fixed pressure has remained constant.
    Since we fixed this and the dodgy off on switch in June the boiler has not missed a beat. Just hope I am not tempting fate! We have just fitted a new Worcester to our other cottage.
    Good luck.
    Boilergonbust
     
    • Thanks Thanks x 1
  14. rwharry1

    Joined:
    8 Nov 2011
    Messages:
    1
    Thanks Received:
    1
    Location:
    Gwent
    Country:
    United Kingdom
    I have had the same problems described here regarding intermittent loss of pressure on my Grant Vortex Combi 36kw. Have fitted brand new expansion vessel and PRV and no obvious leaks (either on CH system or boiler). Apparently Grant have had problems with the control panel on these models - after some arguing they have now given me a new e type panel. I hope this may resolve the problems.

    I would be interested to hear of any others that have had problems with pressure dropping (or this model generally), what the problem/fault has been and if Grant have admitted they have a fault.
     
    • Thanks Thanks x 1
  15. boilerspolier

    Joined:
    8 Nov 2011
    Messages:
    1
    Thanks Received:
    0
    Location:
    Cambridgeshire
    Country:
    United Kingdom
    I have had mine installed a couple of weeks ago and the pressure has dropped low enough to switch system off. no leaks in boiler or pipework but hoping it is just a air lock in system which is working it's way out. exact same boiler
     

Share This Page