Mira electric shower

Discussion in 'Plumbing and Central Heating' started by ally12345, 14 Mar 2007.

  1. ally12345

    Joined:
    14 Mar 2007
    Messages:
    7
    Thanks Received:
    0
    Location:
    Cleveland
    Country:
    United Kingdom
    Hi,
    I currently have a 9KW Mira electric shower which been fitted in the house since I bought it (5 years) and probably a lot longer (anything up to 20 years). The water pressure is poor from the shower however the water pressure in the rest of the house is o.k. I took the front cover of the shower today and checked and cleaned the filter, which was fairly clean and has not improved the pressure. In the past I have also replaced the hose and shower head these have also had no effect on the pressure produced.
    I guess I have a number of questions:-
    Is there anything further I can do to improve my pressure without buying a new shower?
    Will upgrading to a 10.8KW shower have much improvement?
    Do I need to bite the bullet and go to a power shower if I want to experience a really powerful shower? :confused:

    Thanks! : :
     
  2. RockallPlumbingBmth

    Joined:
    14 Mar 2007
    Messages:
    9
    Thanks Received:
    0
    Location:
    Bournemouth
    Country:
    United Kingdom
    for starters changing the head back to an original mira head would help because they are designed for the specific shower if you have too many holes in the head it decreases the pressure. if its a mira sport you will be paying around £30- £40 for a head. Also as you shower was fitted a long time ago you cable size will probally be 6mm but i has to be 10mm for anything more powerful than 9kw this makes no difference to the flow you get it just heats the water effeciently. also has you heat on the shower decreased when you changed the hose and head?
     
  3. ally12345

    Joined:
    14 Mar 2007
    Messages:
    7
    Thanks Received:
    0
    Location:
    Cleveland
    Country:
    United Kingdom
    Thanks!
    My pressure, flowrate and temperature all remained the same after I changed the hose and head.
     

Share This Page