1. We are pleased to announce the 'Home Automation' forum. Click here to get involved!

Trianco Aztec/ Centaurplus C27 problems?

Discussion in 'Plumbing and Central Heating' started by Rob20236, 12 Apr 2012.

  1. Rob20236

    Joined:
    12 Apr 2012
    Messages:
    1
    Thanks Received:
    0
    Location:
    Devon
    Country:
    United Kingdom
    Hi.
    Have just moved into a flat with a trianco Aztec electric boiler paired with a Horstmann Centaurplus C27 programmer. Apart from a big white tank and (supposedly) knowing how to set the timer, that's as far as my knowledge goes with this system. My problem as far as I know is the timer. When I switch on the hw the water doesn't heat but the central heating gets hot!?. The ch light on the timer doesn't come on but the central heating defiantly gets hot. Same if I press the boost button, I hear the system start an the central heating comes on again, without the water getting hot. If I press the ch button the heating comes on fine. In short both the hw and ch buttons only turn on the ch?!
    There is a separate immersion switch I can use to heat the water, but this can become expensive I I forget to turn it off.
    Any help please?
    Sorry for the long first post and thanks in advance :)
     
  2. DeltaT2

    Joined:
    24 Aug 2011
    Messages:
    1,400
    Thanks Received:
    165
    Location:
    Glasgow
    Country:
    United Kingdom
    With most leccy flow through boiler systems Rob; the HW is just heated by the immersion heaters, to confirm this do you have two immersion heaters?

    The C27 is a two channel programmer, but if your HW is heated independly of the boiler, then it should just be a single channel, controling the CH only.

    Any more questions mate, take some digi photos of your system & upload them............ ;)
    HTH
     

Share This Page