1. We are pleased to announce the 'Home Automation' forum. Click here to get involved!

whirlpool dishwasher green light flashing 7 times

Discussion in 'Appliances' started by maverico, 14 Aug 2008.

  1. maverico

    Joined:
    17 Feb 2008
    Messages:
    36
    Thanks Received:
    0
    Country:
    United Kingdom
    just connected whirlpool dishwasher adp4542, it has been moved and stored for 6 months, the machine starts up the cycle sounds ok then after about 2 minutes it stops then shows the green light flashing , when i press the green light swith for 3 seconds it starts up again then runs for another few minutes this continues time after time

    before i call the engineer out to repair it is there anything i can do myself to try to fix it
     
  2. Sleepyhead

    Joined:
    2 Apr 2006
    Messages:
    1,896
    Thanks Received:
    27
    Country:
    United Kingdom
    really depends on the age of the machine.
    However, start it up, when the light flashes count the flashes between pauses. the number of flashes equals an error code.
     
  3. maverico

    Joined:
    17 Feb 2008
    Messages:
    36
    Thanks Received:
    0
    Country:
    United Kingdom
    the machine is 3 years old only
     
  4. maverico

    Joined:
    17 Feb 2008
    Messages:
    36
    Thanks Received:
    0
    Country:
    United Kingdom
    thanks sleepyhead

    there are 7 flashes in between pauses , any idea what error it may be anybody?????
     
  5. Sleepyhead

    Joined:
    2 Apr 2006
    Messages:
    1,896
    Thanks Received:
    27
    Country:
    United Kingdom
    It's a flow meter failure.
    Unplug the machine from the wall socket.
    Take the left hand panel off (looking from front).
    Looking at it from the side, at the bottom right of the plastic fill chamber you'll see a water wheel, disconnect the plug from this, clean the contacts on the small pcb, tighten the connections on the plug and plug it back on.
    Reassemble the machine. Plug it back into the wall socket, reset it and try a program again.
     
    • Thanks Thanks x 1
  6. Paramonte

    Joined:
    4 Sep 2008
    Messages:
    1
    Thanks Received:
    0
    Country:
    United Kingdom
    Maverico, I have the same problem in my machine. Did the Sleepyhead advise work?

    By the way, thank you Sleepyhead for taking the time to help
     
  7. Funkster99

    Joined:
    5 Jul 2010
    Messages:
    2
    Thanks Received:
    0
    Location:
    Buckinghamshire
    Country:
    United Kingdom
    Sleepyhead

    I do not have a left panel to remove!

    I have a ADG7460

    your expert opinion please?
     
  8. durks

    Joined:
    7 Dec 2010
    Messages:
    2
    Thanks Received:
    0
    Location:
    London
    Country:
    United Kingdom
    I have a caple di441 which is essentially a rebadged whirlpool. I was getting the 7 (sometimes 6) flashes thing exactly as discribed at the beginning of this thread. I followed sleepyhead's instructions as best I could - taking the whole dishwasher out from under the worktop (its a built-in), unscrewing the entire left side of the machine to expose this large relatively thin/flat white plastic container with water in it. I took out the tube which enters from the top of the machine into the top righthandside of the plastic container. I then unplugged and cleaned (by blowing to remove dust etc) the pcb (or printed circuit board thing) at the bottom of the plastic container. Reinserted both the tube and the pcb, started another cycle and hey presto, sleepyheads your uncle, it worked. Saved me a fortune and a lot of washing up.

    cheers. ps. i never post these sorts of things on forums like this but I was so grateful that this gem worked that I thought it was only fair that I spread the love!
     
  9. thedudeNL

    Joined:
    30 Apr 2011
    Messages:
    2
    Thanks Received:
    0
    Country:
    United Kingdom
    Hi Sleepyhead,

    I had this code 7 on my DWF B00 Ikea dishwasher coming up pretty fast after starting a program and tried the solution here to take off the cover and tighten the contacts on the plug that is connected to the little printboard. It seemed as if the device worked better, it could almost finish an entire program, but after maybe an hour the beeps and code 7 still come up....

    Any other trick I could try?

    Maybe I can try cleaning the contacts with contactspray, the board looks pretty new to me though!

    Thanks

    Marcel
     
  10. mickey1888

    Joined:
    31 May 2011
    Messages:
    1
    Thanks Received:
    0
    Country:
    United Kingdom
    Hi, i have the same problem with my whirlpool DWF B00, stops on rinse, beeps and light flashes 7 times. Salt water light has been permanently on since we bought it 2nd hand and has stayed on even though i have filled it with salt. Any suggestions what to do? its fitted so i thought i'd ask first.
    Thanks, Mickey.
     

Share This Page