DIYnot
Local | Network
   DIYnot > Forums
Local | Network
DIYnot Network Local DIYnot Network Local  
  Forum IndexForum Index     RulesRules    HelpHelp     Join FREERegister Free     About CookiesCookies     SearchSearch     LoginLogin 

Glow Worm Space Saver mk 2


 
Post new topic   Reply to topic    DIYnot.com Forum Index > Plumbing and Central Heating
Search this topic :: View previous topic :: View next topic  
Author Message
trix

from United Kingdom

Joined: 24 Sep 2008
Posts: 2
Location: Bedfordshire,
United Kingdom

PostPosted: Wed Sep 24, 2008 9:07 pm Reply with quote

Can anyone help i have a Glow Worm Space Saver mk 2 running on lpg, got new gas bottles and went to fire it up and nothing held in the button for ages and kept trying the igniter but it just wont fire!
I have had the covers off and it doesn't seem there is any gas getting through as i cant smell gas when i have held the button in for ages??? it was all working last winter and has been off for about 6 months??
Back to top
 Alert Moderators

If you do not want to see this advert, click here to login or if you are new click here to join free.
giblets

from United Kingdom

Joined: 03 May 2007
Posts: 3089
Location: Surrey,
United Kingdom
Thanked: 340 times

PostPosted: Wed Sep 24, 2008 9:27 pm Reply with quote

Stale gas in the pipework.

You need a (LPG) RGI to purge the pipework through.
Back to top
 Alert Moderators
gas4you

from United Kingdom

Joined: 23 Feb 2007
Posts: 17506
Location: Norfolk,
United Kingdom
Thanked: 716 times

PostPosted: Wed Sep 24, 2008 9:55 pm Reply with quote

Check the UPSO on the regulator hasn't operated and shut the gas off.

Very common when bottles have been changed.
Back to top
 Alert Moderators
trix

from United Kingdom

Joined: 24 Sep 2008
Posts: 2
Location: Bedfordshire,
United Kingdom

PostPosted: Thu Sep 25, 2008 4:05 pm Reply with quote

Thanks for the feed back, the situation now is..... i have cleaned out the feed pipe to the boiler and checked that gas is getting to the boiler valve by disconnecting the mail feed in to the valve and gas is reaching there! But still i hold the green button in for aged and nothing happens, the valve is a (Honeywell V4700E) which i have sourced for around the 50 mark but am not sure if this is needed or can i try anything else first maybe thermocouple???
Back to top
 Alert Moderators
Terrywookfit

from Antarctica

Joined: 19 Jul 2007
Posts: 2287
Location: Antarctica
Thanked: 259 times

PostPosted: Thu Sep 25, 2008 6:17 pm Reply with quote

The pilot injector will probably be blocked.
Not a DIY job!
Back to top
 Alert Moderators
twgas

from United Kingdom

Joined: 26 Oct 2007
Posts: 4699
Location: Kent,
United Kingdom
Thanked: 390 times

PostPosted: Thu Sep 25, 2008 6:21 pm Reply with quote

try a RGI - gas can be dangerous in the wrong hands.
Back to top
 Alert Moderators
Search this topic :: View previous topic :: View next topic  
Post new topic   Reply to topic    DIYnot.com Forum Index > Plumbing and Central Heating All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Similar Topics   Replies   Views   Posted 
Blown 3amp Fuse on Glow Worm Space Saver 10 1780 Mon Oct 08, 2007 9:42 am
Glow worm Space saver MK2 ~ wont fire the main flame. 2 780 Wed Sep 12, 2007 6:54 am
GLOW WORM SPACE SAVER 38 GAS VALVE WANTED 11 1960 Fri Oct 19, 2007 9:22 am
Urgent: Glow-worm Space-saver Mk 11 5 640 Sun Dec 02, 2007 10:22 pm
Glow worm space saver mk 2 water problem 18 1300 Tue Jan 08, 2008 5:04 pm


 
DIYnot
Find an Expert | Find a Supplier | Search DIYnot.com
Network | Advertising | Newsletter
DIY | DIY How To | @home | DIY Wiki | DIY Forum
By using this site you agree to our Terms of Service / Disclaimer.
Please read our Privacy Policy. Copyright © 2000-2014 DIYnot Limited.