DIYnot
Local | Network
   DIYnot > Forums
Local | Network
DIYnot Network Local DIYnot Network Local  
  Forum IndexForum Index     RulesRules    HelpHelp     Join FREERegister Free     About CookiesCookies     SearchSearch     LoginLogin 

Worcester-Bosch Wireless Digistat Problem


 
Post new topic   Reply to topic    DIYnot.com Forum Index > Plumbing and Central Heating
Search this topic :: View previous topic :: View next topic  
Author Message
shakeydave

from United Kingdom

Joined: 18 Feb 2009
Posts: 2
Location: Wiltshire,
United Kingdom

PostPosted: Wed Feb 18, 2009 7:09 pm Reply with quote

Hi,

I've searched the forum already and found that someone has had the same issue as me but there wasn't any conclusion so rather than me explain it all again this is the link to the previous guy's message:

[url]
http://www.diynot.com/forums/viewtopic.php?t=122087&start=0&postdays=0&postorder=asc&highlight=[/url]

The forum rules ask for the following info:

1) Boiler make / model (gas or oil)
Worcester/28i junior Gas Combi Boiler

2) What is / is not happening.
The wireless Digistat is not starting the heating (see further info below)

3) Has ANYTHING else been done or changed recently.
Just changed batteries in Digistat Transmitter

4) When did the problem start?
After changed batteries - wouldn't re-initiase rf connection

5) When does it happen? eg, heating coming on or going off.
Doesn't come on

6) Anything else you feel may be of relevance.
So, I changed the batteries of the Worcester Digistat Transmitter (to the letter of the instructions), then tried to re-initialise the rf connection by pressing the receiver buttons 1&2. Saw the correct quick flash of the red LED but then it goes solid red permanently an the Digistat Flame symbol coming on doesn't fire up the boiler

The forums I've read so far all seem to point to a faulty Receiver, I just don't understand why it would fail from simply losing it's signal when I changed the batteries in the Transmitter.

Are there any checks I can do on the PCB of the Receiver to see if it has indeed developed a fault (I'm from a technical background with electronics experience) no good without drawings or known voltages at key test points.

It still fires up the boiler when I press Overide.

Have got pics of Transmitter and Receiver in situ if that helps?

Any help gratefully received.
ps Sorry for long post.
Back to top
 Alert Moderators

If you do not want to see this advert, click here to login or if you are new click here to join free.
cider

from United Kingdom

Joined: 25 Jul 2008
Posts: 3385
Location: Bristol,
United Kingdom
Thanked: 513 times

PostPosted: Wed Feb 18, 2009 7:28 pm Reply with quote

Did you wait for the flashing lights to stop on the receiver before you re- installed the batteries?
Back to top
 Alert Moderators
shakeydave

from United Kingdom

Joined: 18 Feb 2009
Posts: 2
Location: Wiltshire,
United Kingdom

PostPosted: Wed Feb 18, 2009 9:56 pm Reply with quote

cider wrote:
Did you wait for the flashing lights to stop on the receiver before you re- installed the batteries?


Seriously, I could kiss you! Mate I don't know how I didn't try that before but it just worked - you've saved me 200 and a whole lot of grief off the missus for wasting money!

I shut it all down took the batteries out, fired it up, pressed/held button 1, pressed button 2 - quick Red LED flash then went out for the first time.
Put the batteries in and hey presto. Boiler fired!

Great job, thanks for the help!
Dave.
Back to top
 Alert Moderators
Search this topic :: View previous topic :: View next topic  
Post new topic   Reply to topic    DIYnot.com Forum Index > Plumbing and Central Heating All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Similar Topics   Replies   Views   Posted 
Drayton Digistat RF3 Wireless thermostat problem 7 1080 Sun May 02, 2010 11:21 am
Drayton digistat RF2 wireless system - PROBLEM! 6 3720 Tue May 06, 2008 8:09 am
Drayton Digistat Wireless problem 2 320 Wed Oct 27, 2010 5:30 pm
Drayton digistat RF2 wireless problem 7 1660 Sun Sep 19, 2010 3:23 pm
Wireless Digistat renewal 6 80 Wed Feb 20, 2013 6:33 pm


 
DIYnot
Find an Expert | Find a Supplier | Search DIYnot.com
Network | Advertising | Newsletter
DIY | DIY How To | @home | DIY Wiki | DIY Forum
By using this site you agree to our Terms of Service / Disclaimer.
Please read our Privacy Policy. Copyright © 2000-2014 DIYnot Limited.