DIYnot
Local | Network
   DIYnot > Forums
Local | Network
DIYnot Network Local DIYnot Network Local  
  Forum IndexForum Index     RulesRules    HelpHelp     Join FREERegister Free     About CookiesCookies     SearchSearch     LoginLogin 

Advice re possible boiler problem Ideal Icos HE24


 
Post new topic   Reply to topic    DIYnot.com Forum Index > Plumbing and Central Heating
Search this topic :: View previous topic :: View next topic  
Author Message
redfox

from United Kingdom

Joined: 07 Oct 2009
Posts: 4
Location: Buckinghamshire,
United Kingdom

PostPosted: Wed Oct 07, 2009 11:47 am Reply with quote

Hi everybody newbie here this is my first post icon_smile.gif

Must say what a fantastic site all my previous googleings have led me back to here. This is what the internet is all about!

I think my boiler/system may need some attention,

System details

Boiler Ideal Icos HE24 (sited downstairs in utility room) with a Drayton LP241 programmable timer

In airing cupboard upstairs Heatrae Sadia Megaflo CL210 hotwater cylinder

Grunfoss pump ups 15-60 130 P/N 59526609
PC: 0505 (3 Speed pump)

Drayton Zone Valve actuator

Silver box spamped with honeywell (presume a thermostat?)

Red expansion tank with pressure guage

This system provides heating and hot water for a 4 bedroomed detached house and has been very efficient until last Monday evening

Will list events as they happened,

Heard noises not sure were they were coming from checked outside and upstairs an hour later discovered it was water rumbling through the boiler
boiler status C burner led constantly flashing after a short while the boiler fired up and the burner switched to permantly on but after 30 seconds returned to flashing (the house was heated ok and also hot water).

Heating was turned off but water heating left on as per usual the boiler continued to behave like this all evening.

Next day contacted Ideal direct as I thought they would be the best people to look at the boiler also this boiler is due for a service.

Ideal told me they could not repair and service the boiler ata the same time! Service would be £80 which I thought is probably the going rate?

Then I was shocked to be told fixed price repair would be an extra £240 so I thanked caller for info and decided to check system and get further advice as not sure if this price for repair would be good value for money.

Have since discovered when the timer is turned off the boiler still keeps firing up!!!!

Also turned the boiler off this morning and could still a noise coming from airing cupboard. The pump is still running continually several hours after boiler turned off. It was set at highest speed but have turned to lowest whilst boiler off.

Any ideas what my problem could be so that I can decide wether Ideal fixed price repair is a good option in my case. Did not ask at the time what this covers.

Also re the service once this is resolved should I be better off joining one of these maintainance schemes which include an annual service.

Sorry this post is long but I wanted to give all the details

Hope somebody may be able to help.

Thanks in advance

[/code]
Back to top
 Alert Moderators

If you do not want to see this advert, click here to login or if you are new click here to join free.
mickyg

from United Kingdom

Joined: 24 Aug 2005
Posts: 15918
Location: Hertfordshire,
United Kingdom
Thanked: 3186 times

PostPosted: Wed Oct 07, 2009 11:53 am Reply with quote

redfox wrote:

Red expansion tank with pressure guage


what does it read on the pressure guage? it should be around 1-1.5bar.
Back to top
 Alert Moderators
redfox

from United Kingdom

Joined: 07 Oct 2009
Posts: 4
Location: Buckinghamshire,
United Kingdom

PostPosted: Wed Oct 07, 2009 12:05 pm Reply with quote

Hi there

The system pressure is spot on as you describe and when I do have the boiler switched on it is still heating the radiators and the hot water
Back to top
 Alert Moderators
shambolic

from United Kingdom

Joined: 25 Aug 2008
Posts: 1417
Location: United Kingdom
Thanked: 361 times

PostPosted: Wed Oct 07, 2009 6:38 pm Reply with quote

No mate I work for Ideal but your problem is one of your zone valve end switches in the airing cupboard stuck and sending 240v to pump and boiler when no demand.
This will cause the banging(overheating noises in the boiler) and the boiler could eventually badly overheat if bypasss not opened enough either.
A decent engineer could check both valves and replace faulty one in Jig time!
Approx 30 mins max to diagnose and fit new one if they have it with them!
(if just head of either and wired required)
Back to top
 Alert Moderators
redfox

from United Kingdom

Joined: 07 Oct 2009
Posts: 4
Location: Buckinghamshire,
United Kingdom

PostPosted: Wed Oct 07, 2009 7:02 pm Reply with quote

Thanks for your reply Shambolic

Whilst upstairs twenty mins ago I discovered the pump had turned off
ran downstairs to check boiler and it looked as it should status 0 not firing up.

But after twenty mins (reading bedtime stories etc etc ) I returned to find boiler behaving as it had done status c burner led flashing would this normally happen if the valves were stuck open or could this be some thing else.

Thanks
Back to top
 Alert Moderators
shambolic

from United Kingdom

Joined: 25 Aug 2008
Posts: 1417
Location: United Kingdom
Thanked: 361 times

PostPosted: Wed Oct 07, 2009 8:36 pm Reply with quote

Was the pump also on??
If so you have a problem with a permanent feed intermittently turning on boiler and pump.
You would nee to test if power going to motor side of valve and then power at both sides of end switches.
If power to motor side but timer off(whether hot water or heating) then switches in timer faulty.
If no power to motor side (again on either one) but power to the both sides of end switches,(normally grey and orange wires) then microswitches sticking intermittently.
Normally the sunvic/danfoss/acl before the honeywell one but they do go to.
To test which one it is I normally disconnect one(while live if in fault conditions icon_eek.gif ) and if it stops it that valve if not its the other one.
But not something you should really be messing with unless you know what you are doing icon_biggrin.gif
Back to top
 Alert Moderators
redfox

from United Kingdom

Joined: 07 Oct 2009
Posts: 4
Location: Buckinghamshire,
United Kingdom

PostPosted: Thu Oct 08, 2009 8:24 am Reply with quote

Thanks for your reply Shambolic

No the pump was not running and when boiler returned to status 0

Could this be something just sticking!

unless something simple I can check would not attempt to fiddle I just need to understand what might be happening so that I can make decide if fixed price repair not good value for money in this particular case.

I also like to have some basic understanding of the problem so I can understand any repair process an engineer might do.

Sorry if I sound like a bit of an anorak but hubby not interested in this stuff his eyes just glaze over when I mention anything technical icon_lol.gif so all household maintenance is left to me!
Back to top
 Alert Moderators
johnski15

from United Kingdom

Joined: 14 Dec 2009
Posts: 6
Location: Yorkshire,
United Kingdom

PostPosted: Mon Dec 14, 2009 8:18 am Reply with quote

Good Morning,

I have had a very similar problem with my Heating system - the system is exactly 3 years old this month (December 2009).

In a nutshell...The heating controls...these are:

Danfoss TP5000 Hard wired inside house that controls the Central Heating set at 20C on at 4.30pm to off (15C) at 8.45pm. The flame on the panel re-ignites the boiler if the air temp falls in the house.

Danfoss FP 715 Si in the garage (next to boiler and tank) that only controls the hot water we use; set from 6am to 6.20am and 5.50pm to 6.20pm.

These are both wired into the fused spur powered Danfoss terminal box as is the boiler, pump, tank thermostat and the actuator valves.

This is my problem:

The Danfoss TP5000 ignites the boiler at 4.30pm and heats the house up nicely.

If the program is run through its entirety the flame disappears and the boiler keeps going....the temperature of the radiators keeps increasing and the house is like a sauna.

I have to switch the boiler off at the fused spur panel (as the pump sill keeps going if I turn the boiler off at its switch - Which is strange??) to get the heating off as the Danfoss TP5000 will not control the boiler at this point,

However I have had the panel tested and even swapped it with my next door neighbour (they have same system) there is no fault on mine and the same problem occurs with the perfectly working Danfoss TP5000 from next door.

The next thing I was advised on was the actuator 2 port valve on that controls the central heating. I have changed this with one I borrowed again from next door, this was a perfectly good Danfoss He24 2 port valve actuator.....again the same problem persists....I now have 2 Danfoss He24 valves...that presumably both work fine!!

Finally, the worst thing of it all, when I try to demonstrate the problem I have with the continuous running of the boiler even when the TP5000 has told the boiler to switch off is:

When I manually turn the TP5000 on to fire the boiler and central heating it does fine, I can leave it 10, 20, 30, 40 minutes then turn the thermostat to the non-flame off temperature e.g. 15C, 18C etc... The boiler turns off nicely...

I am now stuck on what is happening.....Is it the thermostats inside the boiler not operating properly or something I am totally missing???

The Central heating and Hot water work fine, itís the boiler not shutting down when it is told to by the Danfoss TP5000 that is doing my nut in!!

Thanks for any support!!
Back to top
 Alert Moderators
Search this topic :: View previous topic :: View next topic  
Post new topic   Reply to topic    DIYnot.com Forum Index > Plumbing and Central Heating All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Similar Topics   Replies   Views   Posted 
Problem with IDEAL ICOS HE24 boiler 3 540 Tue Mar 23, 2010 10:28 am
Ideal Icos HE24 Problem..Please help 12 1680 Mon Dec 14, 2009 8:18 am
LEAKING IDEAL ICOS HE24 BOILER 8 1100 Mon Dec 15, 2008 5:46 pm
Ideal Icos HE24 Boiler Fault Code 9 23920 Sun Nov 02, 2008 5:50 pm
Icos Ideal HE24 boiler 3 240 Thu Sep 30, 2010 7:23 pm


 
DIYnot
Find an Expert | Find a Supplier | Search DIYnot.com
Network | Advertising | Newsletter
DIY | DIY How To | @home | DIY Wiki | DIY Forum
By using this site you agree to our Terms of Service / Disclaimer.
Please read our Privacy Policy. Copyright © 2000-2014 DIYnot Limited.