DIYnot
Local | Network
   DIYnot > Forums
Local | Network
DIYnot Network Local DIYnot Network Local  
  Forum IndexForum Index     RulesRules    HelpHelp     Join FREERegister Free     About CookiesCookies     SearchSearch     LoginLogin 

2003 Ford Fiesta 1.4 battery light is on


 
Post new topic   Reply to topic    DIYnot.com Forum Index > Car Repairs / Maintenance
Search this topic :: View previous topic :: View next topic  
Author Message
alan666

from United Kingdom

Joined: 14 Apr 2010
Posts: 2
Location: United Kingdom

PostPosted: Wed Apr 14, 2010 7:22 pm Reply with quote

The battery light on a 1.4 2003 Fiesta is on constantly. When I put the battery on a battery charger/conditioner, it reported the battery was poor or sulphated and couldn't be recovered so I replaced it but the battery light is still on. I have checked voltages and the alternator was not charging so I removed the smart charge plug and it charges at 14v. I have read elsewhere that pin 3 on the Focus smart charger plug should be at the same voltage as the battery as it is a reference voltage. Don't know if it is the same on the Fiesta so I checked, but I wasn't sure which was pin 1 and which pin 3. One has around 4v the other 8v so neither has 12v. Any ideas what else I could check?
Back to top
 Alert Moderators

If you do not want to see this advert, click here to login or if you are new click here to join free.
^neo^

from United Kingdom

Joined: 14 Jun 2006
Posts: 1707
Location: Surrey,
United Kingdom
Thanked: 43 times

PostPosted: Thu Apr 15, 2010 8:30 am Reply with quote

sounds like the voltage regulator in the alt has died.
Back to top
 Alert Moderators
Spark123

from United Kingdom

Joined: 02 Jun 2005
Posts: 14258
Location: Cumbria,
United Kingdom
Thanked: 409 times

PostPosted: Thu Apr 15, 2010 3:57 pm Reply with quote

Is it a silver calcium type battery? What type did you replace it with?
Back to top
 Alert Moderators
diydazzler

from United Kingdom

Joined: 05 Feb 2010
Posts: 99
Location: Staffordshire,
United Kingdom
Thanked: 1 time

PostPosted: Thu Apr 15, 2010 4:06 pm Reply with quote

Put a volt meter across the battery with the engine running and you should see around 14 volts.
If its less ie 12v then the alternator needs looking at
Back to top
 Alert Moderators
alan666

from United Kingdom

Joined: 14 Apr 2010
Posts: 2
Location: United Kingdom

PostPosted: Thu Apr 15, 2010 7:11 pm Reply with quote

It is an AC Delco Calcium battery. With the 3 pin plug disconnected from the alternator there is over 14v measured accross the battery so the alternator is charging as it should but when the plug is reconnected, it stops charging. So the problem is somewhere with the smart charging circuit.
Back to top
 Alert Moderators
Burnerman

from United Kingdom

Joined: 07 Feb 2008
Posts: 11418
Location: Northumberland,
United Kingdom
Thanked: 2313 times

PostPosted: Thu Apr 15, 2010 7:35 pm Reply with quote

Ye gods and this is what Ford call progress.....
They developed smart charging to cope with the new calcium batteries. This effectively boosted the charging voltage to around 15v - but it was controlled by the cars ECU - not by the alternator.
Removing the smart charge plug allows the alternator voltage regulator to take over and the battery will still be charged - although the battery light may still be on.
Check the wiring condition as it leaves the smart charge plug - if one conductor is broken, frayed or burnt you get your symptoms.
(I got this from a Transit TSB by the way...it may apply to yours).
Hope this helps!
John icon_smile.gif
Back to top
 Alert Moderators
Search this topic :: View previous topic :: View next topic  
Post new topic   Reply to topic    DIYnot.com Forum Index > Car Repairs / Maintenance All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Similar Topics   Replies   Views   Posted 
ford fiesta 2003 diesel injector seal replacement 8 5440 Wed Feb 28, 2007 12:39 pm
HELP! Engine Management light on Corsa C 1.0 12v 2003 7 21280 Tue Feb 16, 2010 10:27 pm
ABS light vw polo 2003 1.2 petrol engine 8 7880 Fri Jul 29, 2011 8:34 pm
VW POLO 2003 1998 cc petrol Engine Light On 11 380 Mon Sep 24, 2012 5:54 pm
VW POLO 2003 1198CC Petrol Engine Light On 32 16340 Fri Jul 09, 2010 8:01 pm


 
DIYnot
Find an Expert | Find a Supplier | Search DIYnot.com
Network | Advertising | Newsletter
DIY | DIY How To | @home | DIY Wiki | DIY Forum
By using this site you agree to our Terms of Service / Disclaimer.
Please read our Privacy Policy. Copyright © 2000-2014 DIYnot Limited.