DIYnot
Local | Network
   DIYnot > Forums
Local | Network
DIYnot Network Local DIYnot Network Local  
  Forum IndexForum Index     RulesRules    HelpHelp     Join FREERegister Free     About CookiesCookies     SearchSearch     LoginLogin 

Corsa - Sluggish when cold, engine rattles at mid-high speed


 
Post new topic   Reply to topic    DIYnot.com Forum Index > Car Repairs / Maintenance
Search this topic :: View previous topic :: View next topic  
Author Message
PG

from United Kingdom

Joined: 13 Apr 2005
Posts: 32
Location: United Kingdom

PostPosted: Thu Sep 22, 2005 1:22 pm Reply with quote

I have a R reg 1.0 L Corsa which was running OK until recently.

I am competent enough to have changed the oil + filter, coolant, spark plugs & air filter at the beginning of the year.

BUT lately the car feels sluggish & has difficulty accelerating. When cold pushing the pedal seems not to generate much of a response in the speed the engine turns until the car has warmed up a little.

Also, on the motorway when accelerating beyond 60 mph a rattling noise is heard from the engine. I know this is the case with small engines but before it only happened when the car was pushed really hard.

Can anyone suggest what I should check/change or am I better off just taking it to a garage and getting charged loadsa money for stuff that I can probably do myself (with instructions of course).

Cheers,
PG
Back to top
 Alert Moderators

If you do not want to see this advert, click here to login or if you are new click here to join free.
BazzaS

from United Kingdom

Joined: 30 Dec 2003
Posts: 142
Location: Worcestershire,
United Kingdom

PostPosted: Thu Sep 22, 2005 3:12 pm Reply with quote

Give us a pointer, does the rattling vary with engine speed ?
If not it may be something loose which only rattles at certain vibrations.

For sluggishness have you checked all the usual suspects - air filter, plugs and if when cold - the correct operation of the choke (if you have one).
Back to top
 Alert Moderators
PG

from United Kingdom

Joined: 13 Apr 2005
Posts: 32
Location: United Kingdom

PostPosted: Fri Sep 23, 2005 12:39 pm Reply with quote

Thanks for your reply BazzaS.

The rattling noise used to occur when accelerating hard whilst the car is already doing 60. But now it happens when accelerating through the gears.

For example, I'll change to 3rd gear at about 20mph & the engine rattles as if it is struggling. The noise fades away at the higher end of the gear range but is then heard again when changing to 4th (at 30 mph). Diminishes when accelerating from 35 to 45 and then comes back when changing to 5th gear (45mph). It then goes away until I get to about 60mph.

The noise goes away if I ease of the accelerator but I'm not exactly flooring it - it's only a 1.0 L car.

I suppose you could say that the noise is there when accelerating at low revs. I don't know if it's accurate to describe it as a 'tappety' noise.

Also, the cars idles irregularly. The idle speed of the engine when stationary seems to dip & rise in a cycle. I don't know if this is related to the other problem. Also when idling the engine makes a tapping noise but Vauxhall told me this is normal for a 3 cylinder car!
Back to top
 Alert Moderators
BazzaS

from United Kingdom

Joined: 30 Dec 2003
Posts: 142
Location: Worcestershire,
United Kingdom

PostPosted: Fri Sep 23, 2005 12:53 pm Reply with quote

Well, if you hadn't said it was a tappet-like sound I would have suggested that it was pinking under load.
Typically pinking occurs when either the wrong (lower) grade fuel is used or when the ignition is out - retarded I think. It would also account for sluggishness.
So I would recommend you check the ignition system (plugs points and the like) as well as the ignition timing. You may need a garage for this latter aspect.
Best of luck
Back to top
 Alert Moderators
keyplayer

from United Kingdom

Joined: 20 Jul 2003
Posts: 1480
Location: United Kingdom
Thanked: 20 times

PostPosted: Fri Sep 23, 2005 1:27 pm Reply with quote

You say you changed coolant earlier in the year - is cooling system functioning properly now? Overheating causes pinking and rough running as you describe. Just a thought. Is your heater working?
Back to top
 Alert Moderators
jonnyfishing

from United Kingdom

Joined: 28 Feb 2005
Posts: 587
Location: Manchester,
United Kingdom
Thanked: 27 times

PostPosted: Fri Sep 23, 2005 4:33 pm Reply with quote

PG

The timing and idling speed is controlled by the E.C.U. and not adjustable.I think your problem lies with one of the sensors,this can only be identified with a fault code reader.I'm sure you will find some local person with the equipment to read it for about 25.It's better than trying to guess and it will be cheaper in the long run.

icon_eek.gif icon_eek.gif icon_eek.gif
Back to top
 Alert Moderators
cjbigboy

from United Kingdom

Joined: 10 Sep 2005
Posts: 111
Location: Londonderry,
United Kingdom
Thanked: 1 time

PostPosted: Sat Sep 24, 2005 8:24 pm Reply with quote

Couple of things to check.

1.0 Corsa B's upto 2000 model are notorious for idle speed problems.

Idle Air control valve is a known problem which can make the idle erratic.
Black Bosch component to the left of the throttle body.
I changed more of these than I care to remember whilst working at my local Vauxhall dealership

EGR valve can also give perfomance & idle problems too.

Usually engine management light would be on with either fault, but have known them to go faulty without bringing the light on.

1.0 Corsa's have a chain driven overhead cam, and I have replaced several chains and faulty tensioners that give you the noise that you have. Worth checking!

hope this helps

cheers

CJ
Back to top
 Alert Moderators
skippster76

from United Kingdom

Joined: 09 Jul 2005
Posts: 240
Location: Birmingham,
United Kingdom
Thanked: 26 times

PostPosted: Sun Sep 25, 2005 10:29 am Reply with quote

Hi i agree with cjbigboy i would change the idle air control valve as i have also done loads of these.
Back to top
 Alert Moderators
PG

from United Kingdom

Joined: 13 Apr 2005
Posts: 32
Location: United Kingdom

PostPosted: Mon Sep 26, 2005 2:18 pm Reply with quote

Thanks folks.

I don't think it's a problem with overheating as the engine temp needle is always near the lower end of the scale.

Does anyone know if it's easy to replace the idle air control valve and how much one costs?

I think it may be best if I take it to a mechanic. As you say cjbigboy it could be the air control valve, EGR valve, cam chain, tensioners and god knows what else.

Does anyone recommend taking it to Vauxhall or will I be paying through the nose for their services?
Back to top
 Alert Moderators
cjbigboy

from United Kingdom

Joined: 10 Sep 2005
Posts: 111
Location: Londonderry,
United Kingdom
Thanked: 1 time

PostPosted: Mon Sep 26, 2005 4:52 pm Reply with quote

PG wrote:


Does anyone know if it's easy to replace the idle air control valve and how much one costs?



Very easy, three or four torx headed screws, and unclip the multiplug from one end and withdraw from the throttle body. Refitting is the reverse.

Vauxhall part no is 90531999, costs about 90 + vat.

I would suggest that your rattle and erratic idle are separate issues. Replacing the timing chain and tensioner is quite tricky as the whole timing cover has to come off.

No three cylinder car is going to have a smooth idle and they do go up and down a wee bit, but if you are having performance issues too, the IAC valve would be my first port of call.

Another thing to check that I've just remembered. 1.0 Corsa's have a combined exhaust manifold/Catalytic converter. They were well known for cracking the top bracket that attaches the cat to the engine, and that could be rattling. Vauxhall made a replacement bracket kit to cure that fault

cheers

CJ
Back to top
 Alert Moderators
steve_s46

from United Kingdom

Joined: 09 Aug 2005
Posts: 11
Location: Nottinghamshire,
United Kingdom

PostPosted: Mon Sep 26, 2005 6:00 pm Reply with quote

Have a look for any air leaks around the manifold e.g. bad seal, split vacuum hose etc. Extra unmeasured airflow into the engine can cause erratic idle and maybe cause it to run lean at higher revs = pinking. Worth checking before replacing the IACV
Back to top
 Alert Moderators
PG

from United Kingdom

Joined: 13 Apr 2005
Posts: 32
Location: United Kingdom

PostPosted: Wed Dec 07, 2005 2:09 pm Reply with quote

Thanks for all your advice guys.

Cjbigboy, you correctly identified a fault with the EGR valve.

A few weeks ago a light on the dashboard remained lit. The symbol on the light portrays an engine with an electrical spark.

Well the handbook indicated a fault with the engine management system so I took the car to a Vauxhall garage in Buckingham and they connected a handheld computer to it (I didn't know my Corsa was this clever). They detected a fault with the EGR valve.

This garage was excellent. They said they could try cleaning it or they could replace it. I told the mechanic I'd like to try cleaning it myself first & he kindly advised me on what to do. They only charged me 23 for their services.

I didn't know that the coolant passes through a part of the EGR valve so didn't know to partially drain the coolant before removing it. I cleaned the valve with white spirit as I didn't have any carb cleaner. I replaced the part using the same sealing strip - not sure if I should have got a new seal. OK, the experts out there are probably gasping in horror at my methods but the Corsa is now a 2nd car & I felt I had nothing to lose.

After worrying that my car will never start again I turned the key & it fired up beautifully. I drove off immediately & was amazed at the difference in performance. It was accelerating with all the might a 1.0 L Corsa should have. There was no hesitation or dip in power as I pushed the accelerator. Even the idling seemed better although still not completely smooth.

It's only when I looked out the rear window I saw plumes of white smoke coming from the exhaust. It looked like water vapour & I can only assume that water entered the inlet where the EGR valve connects to the engine as I didn't drain the coolant.

I hope this doesn't cause any lasting damage.

There's probably loads more that needs doing (points, timing belt, etc) and I may even tackle the IAC valve but at least now I am in a better position to sell the car and have not had to shell out a couple of hundred quid for someone to replace the EGR valve.

Thanks again folks.
Back to top
 Alert Moderators
keyplayer

from United Kingdom

Joined: 20 Jul 2003
Posts: 1480
Location: United Kingdom
Thanked: 20 times

PostPosted: Wed Dec 07, 2005 2:27 pm Reply with quote

PG wrote:

I hope this doesn't cause any lasting damage.


No,as long as it was just the once on first fire up. You were lucky with that mechanic/garage, I bet most main dealers would be less helpful! Great that you sorted it.
Back to top
 Alert Moderators
cjbigboy

from United Kingdom

Joined: 10 Sep 2005
Posts: 111
Location: Londonderry,
United Kingdom
Thanked: 1 time

PostPosted: Wed Dec 07, 2005 6:19 pm Reply with quote

PG wrote:
Thanks for all your advice guys.


I hope this doesn't cause any lasting damage.

There's probably loads more that needs doing (points, timing belt, etc) and I may even tackle the IAC valve but at least now I am in a better position to sell the car and have not had to shell out a couple of hundred quid for someone to replace the EGR valve.



If you can do the EGR valve, you're more than qualified to do the IAC valve. Nice work, glad you got it sorted

You'll be pleased to know
a: there are no points, its electronic ignition
b: no timing belt to change, its a chain

cheers

CJ
Back to top
 Alert Moderators
Mick Leek



Joined: 16 Nov 2005
Posts: 370
Location: Lao People

PostPosted: Wed Dec 07, 2005 6:36 pm Reply with quote

PG

Noise on engine as rightly said by cjbigboy is the chain...

1.0 corsas had a problem with the cam chain tensioners. these were replaced under warranty if there was an issue.

Lately a lot of the 1.0 litres have been recalled for a new replacement cam chain to be fitted Free of charge. there is a chassis break point so im unsure if yours will be covered. A call to your local Vauxhall dealer will tell you if yours falls within the FREE REWORK. They will check your reg number on the data base.

Replacement of the chain does not require the end cover to be taken off. there is always a quick fix answer. and it is as follows.

Firstly, if you are not that good with the spanners then please DO NOT attemp this.

1, Remove Ignition pack and spark plugs.

2, carefully insert a screwdriver down No1 plug hole and rotate engine to TDC. the screwdriver rising and fallling will tell you when you are there.

3, Remove the rocker cover, being carefull NOT to drop anything down the plug holes,

4, Place the correct size spanner on the inlet cam and then crack off the cam chain sproket securing nut,

5, do the same with the Exhaust cam

6, Split the chain with a chain splitter, Be carefull that the chain does NOT fall in the crankcase.

7, once the chain is split, you get a disposable copper link with the new chain that is designed to temporary connect the new chain to the old one. Connect the two chains together.

8, carefully rotate the crank shaft and feed the new chain into the casing. Rotate fully untill th enew chain travels right around the engine.

9, Once the chain is in place, Remove the temp link and replace with the permanent one.

10, Check timing to ensure nothing has moved and re tighten the cam sprokets.

11, re fit cam cover put plugs back in and away you go...

Check with vauxhall first though... may be that you will get it all done under warranty..

Good Luck,

Mick.
Back to top
 Alert Moderators
Search this topic :: View previous topic :: View next topic  
Post new topic   Reply to topic    DIYnot.com Forum Index > Car Repairs / Maintenance All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Similar Topics   Replies   Views   Posted 
fiat brava rattles and accelerates poorly 10 3240 Sun May 18, 2008 11:28 am
bmw 320i 2001 front window glass rattles-partially opened. 2 60 Sun Aug 28, 2011 5:39 pm
corsa is sluggish 5 100 Sun Oct 16, 2011 4:40 pm
Sluggish 3 cylinder Corsa 2 600 Sun May 10, 2009 7:31 pm
Corsa sluggish when changing gear 7 780 Tue Mar 03, 2009 4:55 pm


 
DIYnot
Find an Expert | Find a Supplier | Search DIYnot.com
Network | Advertising | Newsletter
DIY | DIY How To | @home | DIY Wiki | DIY Forum
By using this site you agree to our Terms of Service / Disclaimer.
Please read our Privacy Policy. Copyright © 2000-2014 DIYnot Limited.