Ariston Genus won't light

N

NickK

a mate of mine has what he describes as and Ariston Genus Micro Combi boiler - wasn't able to give me a model number.

The boiler was working perfectly and then suddenly stopped. It had done this a few times before but always restarted after pressing the reset button.

The pump runs but the fan at the top doesn't. There is no voltage to the fan but if you connect it to an independent supply it runs fine so the only thing we're pretty sure about is its not the fan

There is also a pressure switch up near the fan. This appears to operate when removed from the boiler if you suck air out of it but if you run the fan it doesn't cause the swith to switch.

Just grateful for any ideas really :rolleyes:

many thanks

Nick
 
Sponsored Links
Joined
24 Jul 2003
Messages
24,298
Reaction score
1,416
Location
London
Country
United Kingdom
What you've done will have damaged the boiler such that it'll explode if you get it to work. Get someone who knows what they're doing to look at it. Woof, it'll go.
 
N

NickK

Dont see how testing the fan while its not in the boiler will have damaged the boiler. We isolated the boiler, removed the fan and tested it in the workshop :eek:
 
Sponsored Links

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Top