Audi A7 2015 Difficut to Restart

Joined
8 Nov 2006
Messages
323
Reaction score
9
Location
London
Country
United Kingdom
Hi All

My son's Audi Quattro A7 3.0 TDI 2015 is very difficult to restart after running the engine. When after a run and engine is stopped, if He tries to restart the car the engine cranks but does not start! If he waits a few minutes and cranks it starts immediately. Car has been regularly service no Engine Management Lights and had it scanned with CavComm but no fault codes!

Anyone have a clue what the problem maybe?

Many Thanks

Caesar
 
Sponsored Links
Joined
7 Feb 2008
Messages
23,833
Reaction score
4,781
Location
Northumberland
Country
United Kingdom
This is so typical of a failing crankshaft position sensor - and they don't throw up a fault code either!
Typically, the cold start is instant, every time and the engine behaves perfectly until it's switched off.
Then, when hot, it won't start for love or money but once cooled down a bit its playing ball again until the next time.
Unfortunately I don't know where it is on your V6 but they are typically mounted on top of the bell housing so the thing can look down at the flywheel.
John :)
 
Joined
22 Nov 2009
Messages
1,877
Reaction score
355
Location
Oldham
Country
United Kingdom
Agree, my diesel used to just stop and not start again. By the time I'd killed myself pushing it somewhere safe it would start again perfectly.
 
Sponsored Links
Joined
8 Nov 2006
Messages
323
Reaction score
9
Location
London
Country
United Kingdom
Thanks John and CBDE. You could be right as cold start immediate but even switching off and then back on again immediately it is difficult to start again!
 
Top