Baxi Combi 133HE Plus - So many problems!

Joined
17 Dec 2015
Messages
2
Reaction score
0
Country
United Kingdom
Hi.

Just wondering if anybody could shed some light on the issues I am having with my Baxi Combi.

Although my landlord is responsible for service and maintenance of my boiler, after calling them out about 8 times in last 6 months problems still persist.

Boiler is approx 8 years old.

Started with a leak in the boiler itself (expansion vessel I think) which had to be replaced.
All worked well for some time but then the boiler would randomay cut off. Hot water began running at boiling point, not constantly but it would happen at random. Boiler would be red hot to touch and steaming.

Engineers kept coming and topping up the pressure which keeps dropping. Asked what the cause of this was buy they are very vague.

Checked radiators and pipes myself for leaks. All seems fine.

Same thing continued to happen. Engineers did something to the expansion vessel (recharged it?)

Worked ok for a couple of weeks. Water temp still way to high even though it is turned right down on the boiler itself.

Next I have a massive booming noise, so loud my neighbours could hear it. Boiler was shaking violently. Switched boiler off at mains.

Engineer comes. The burner is completely destroyed. Something to do with too much gas getting through?? See pic below.

Now a week later boiler starts making whooshing sounds and vibrating. I turned boiler off. Bled radiators. 3 out of 5 radiators full of air! Repressurised boiler. Turned back on and all seems OK. Have heating and hot water. No strange noises or scalding water as yet.

Is there anything I need to watch out for? Anything my landlords engineers are missing?

Kind of scared of the damn thing now. Especially after seeing the burner blown to pieces.

Thanks in advance for any advice.
 
Sponsored Links
Joined
14 Mar 2010
Messages
6,113
Reaction score
1,105
Location
Norfolk
Country
United Kingdom
From what you've said about bleeding more air and recharging system, I would suggest all is now ok. That is a known issue with the original burners in that boiler. Just keep an eye on the system pressure when the boiler is cold, it should be around 1bar. It will rise during heating and hot water operation, but that is quite normal. The expansion vessel will take the extra pressure. My guess is that the system wasn't refilled correctly after the new vessel was fitted.
 
Joined
17 Dec 2015
Messages
2
Reaction score
0
Country
United Kingdom
Thank you for your replies.

Pete, I have been watching the pressure on and off today. It seems to sit at 1.5 when the boiler is cold. When I use hot water or heating it falls to about 1. I still seem to have the problem with varying water temperature, which I know can happen with a combi, but mine gets so hot it is unbearable to put my hands under, and I have the temperature dial for the water turned right down. This happens regardless of whether heating has been on or not.
Could there be a problem with the sensor on the temperature dial?

Will be keeping a close eye on things and contacting my landlord with any findings.

Thanks again for your help

Diane
 
Sponsored Links
Top