Baxi solo 50pf

Joined
12 Aug 2014
Messages
5
Reaction score
0
Location
Hampshire
Country
United Kingdom
I have a Baxi Pf Solo boiler which seems to only want to work part time , tonight I turned on hot water then to find after 5 mins of it running the boiler decides to turn out the flame and start ticking as if it's trying to re ignite all the normal lights are on except the burner ,turning off briefly and back on still no joy , but if turned off for 10mins say it will fire up and run again .
It's had a PCB in December 2013 for another issue , any ideas sounds to me as if it's not getting gas butane views would be grateful , I really want to try and avoid calling out someone who wants to chuck parts at it if at all possible
 
Sponsored Links
Joined
14 Mar 2010
Messages
6,113
Reaction score
1,105
Location
Norfolk
Country
United Kingdom
Could be numerous things causing that fault. Most would be gas/combustion related and should be pretty easy to fix. Gas related info is a no no on here, so I would suggest BG on a fixed price repair if you can't trust your local parts chuckers.
 
Joined
12 Aug 2014
Messages
5
Reaction score
0
Location
Hampshire
Country
United Kingdom
Could be numerous things causing that fault. Most would be gas/combustion related and should be pretty easy to fix. Gas related info is a no no on here, so I would suggest BG on a fixed price repair if you can't trust your local parts chuckers.
Thanks
I did have a little search and found someone on here had had a PCB and a gas valve , it ended up being temp sensor on the flow pipe , although I couldn't see this listed in my manual unless there's a couple of names for this part
 
Sponsored Links
Top