Bosch Dishwasher not draining

Status
Not open for further replies.
Joined
16 May 2006
Messages
3
Reaction score
0
Location
London
Country
United Kingdom
We have a 3 1/2 year old Bosch dishwasher, which yesterday stopped draining correctly. We checked that the internal machine filter was clean and re ran it empty and the same problem occurred. We have checked the internal filter is clean (again) and followed the drainage hose and that appears to be clean too. Does this mean that the pump is broken? I saw on some other links that you can fit pumps yourself - how hard is this to do? Also, our machine has heavy usage - what should the standard life expectancy of a machine be? Thanks for your help. :confused:
 
Sponsored Links
Joined
16 May 2006
Messages
3
Reaction score
0
Location
London
Country
United Kingdom
Thanks for your help. There doesn't appear to be a cover as you'd suggested, so I'm not quite sure. My wife has called out a repair man for tomorrow so we'll see.
 
Joined
27 May 2006
Messages
1
Reaction score
0
Country
United Kingdom
I have thte EXACT problem, all lines and drains are clear, no stoppage anywhere. Did you find out what was wrong?

Thanks!
 
Sponsored Links
Joined
28 May 2006
Messages
1
Reaction score
0
Country
United Kingdom
Hi!
And thanks for the tips. I had the same problem with my Bosch Aquatech. I cleaned the bowl at the bottom - found two small pieces of bone - got them out and re-ran the machine. The water still did not drain. Then unscrew the connector between the diswasher pipe and the mains and found the blockage there. Cleared it and re-run the machine again. Works again!! :D
 
Joined
16 May 2006
Messages
3
Reaction score
0
Location
London
Country
United Kingdom
Yes - the problem was a blocked impeller. I'm afraid that we had called a bloke out who charged us £20 but it could have been worse. You live and learn.
 
Joined
11 Nov 2006
Messages
5
Reaction score
1
Location
Leeds
Country
United Kingdom
Many thanks to Sleepyhead for the advice. My dishwasher had exactly this problem - water remaining in the machine, the timer "stuck" on 1 minute and the pump trying to run.

Removed the cover to find 4 fruit pips!! Can't think how, as the filters are removed and cleaned after each wash - but they were there! The drainage to the implellor was virtually blocked.

Removed these and the washer was fine after a "reset" - it seemed to be stuck in emptying mode. All sorted now.

Thanks for the tip Sleepyhead.
h4orth
 
Joined
26 Jun 2004
Messages
39
Reaction score
0
Country
United Kingdom
Posting this for info for future searches.
I had same problem with Exceel dishwasher all seemed clear pipe work impeller. Turned out you must take the left hand side off tp access more pipeage which is where the blockage was.
£60 quid callout! because it wasn't the machine faulty
 
Joined
2 Apr 2006
Messages
1,896
Reaction score
29
Country
United Kingdom
The problem isn't pipework.
It's a failure to rinse foodstuff off dishes & pots before putting them in the dishwasher.
It isn't a waste disposal unit and will block if used as such.
Look after the machine and it will give very little trouble.
 

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Status
Not open for further replies.
Sponsored Links
Top