1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Danfoss RX1 Broken?

Discussion in 'Plumbing and Central Heating' started by wanleg, 16 Jan 2021.

  1. wanleg

    wanleg

    Joined:
    11 Apr 2005
    Messages:
    396
    Thanks Received:
    17
    Location:
    Hartlepool
    Country:
    United Kingdom
    Hi,

    I’m having intermittent problems with central heating not kicking in when RF thermostat is calling for heat (Danfoss TP7000-rf). The CH1 lights red on the RX1 receiver but I don’t hear a click and the boiler (Vaillant 837 Ecotec) does not fire.

    If i remove batteries from thermostat and press CH1 button then red light comes on but again no click or boiler firing.

    This is an intermittent problem that started a few weeks ago...gut feel is the RX1 needs replacing, does anyone agree with this conclusion?
     
  2. Sponsored Links
  3. rbranco

    rbranco

    Joined:
    27 Jan 2018
    Messages:
    182
    Thanks Received:
    23
    Country:
    United Kingdom
    Check the boiler panel and see what status it's in when you expect it to start. Press i button.

    If you have multimeter and are competent you could see if there is any output on the boiler trigger from the RX1.
     
    • Thanks Thanks x 1
    • Like Like x 1
  4. wanleg

    wanleg

    Joined:
    11 Apr 2005
    Messages:
    396
    Thanks Received:
    17
    Location:
    Hartlepool
    Country:
    United Kingdom
    Boiler is showing S.30 which according to manual is “no demand for heat”

    I’ve just took the RX1 off and put a fuse wire loop between terminals 2 and 3, the boiler fired up immediately when turned back on.
     
  5. wanleg

    wanleg

    Joined:
    11 Apr 2005
    Messages:
    396
    Thanks Received:
    17
    Location:
    Hartlepool
    Country:
    United Kingdom
    In the end I just replaced everything with a new Drayton unit from Toolstation...only really cost me abiut £20 more than replacing RX1 alone.
     
    • Like Like x 1
  6. CBW

    CBW

    Joined:
    26 Sep 2019
    Messages:
    9,009
    Thanks Received:
    2,401
    Location:
    North
    Country:
    United Kingdom
    Could it have been the batteries? Likely to be stat, but glad you’re up and running.
     
    • Thanks Thanks x 1
  7. wanleg

    wanleg

    Joined:
    11 Apr 2005
    Messages:
    396
    Thanks Received:
    17
    Location:
    Hartlepool
    Country:
    United Kingdom
    I’d already tried replacing batteries. As boiler wouldn’t fire from manual override button I concluded it was the RX1 receiver.
     
    • Thanks Thanks x 1
  8. DIYnot Local

    DIYnot Local

    Joined:
    3 Sep 2019
    Country:
    United Kingdom

    If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

    Select the supplier or trade you require, enter your location to begin your search.


    Are you a trade or supplier? You can create your listing free at DIYnot Local

     
  9. Sponsored Links
Loading...

Share This Page