1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Devireg / Danfoss 550 heating issue - help appreciated

Discussion in 'Electrics UK' started by artfuldodger128, 28 Oct 2020.

  1. artfuldodger128

    artfuldodger128

    Joined:
    10 Feb 2008
    Messages:
    4
    Thanks Received:
    0
    Location:
    Kent
    Country:
    United Kingdom
    I have a Devireg / Danfoss 550 electric underfloor heating at home, and yesterday the bedroom unit stopped working.

    As a way to try to resolve the problem I swapped out the front and back with a working unit, but unfortunately there is still no heating. See attached pic - the system is showing that there should be heating, but there simply isn't any. From this can I presume there is nothing wrong with the temperature sensor?

    Is there anything else that I can test? Could I test if the heating mat has failed? If so, how? I've a multimeter.

    Many thanks
     

    Attached Files:

  2. Sponsored Links
  3. EFLImpudence

    EFLImpudence

    Joined:
    7 Jul 2010
    Messages:
    37,455
    Thanks Received:
    4,199
    Location:
    Retired to:
    Country:
    Portugal
    You would need to disconnect the two ends of the element (or make sure it is isolated) and measure its resistance - Ω Ohms.
     
  4. DIYnot Local

    DIYnot Local

    Joined:
    3 Sep 2019
    Country:
    United Kingdom

    If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

    Select the supplier or trade you require, enter your location to begin your search.


    Are you a trade or supplier? You can create your listing free at DIYnot Local

     
Loading...

Share This Page