Dishwasher Whirlpool ADG 957

Joined
26 Jan 2016
Messages
4
Reaction score
0
Country
Italy
Problem with Dishwasher Whirlpool ADG 957, 16 years old.
When i launch a program (any program, from rinse to 70° cycle, it's the same), i press start, i close the door, the dishwasher makes some sounds like the pump is working, and it immediately starts beeping (alternate beeps), then the sounds of the pump stops, the beeping continues, i open the door, the beeping stops, the first light (rinse) is on and the light above the start button flashes (continue flashes, it never stops).
So i reset the process by keeping the start button pressed, and i go on to perform the diagnostic test, like this:
- set the program on rinse
- turn off the machine
- while keeping the start button pressed, i turn the machine on, i keep the start button pressed until the light above the start button flashes, then i close the door and the diagnostic tests commences, no beeping sounds, just the machine working and i hear the pump working making the usual normal sounds.
After a very short time (not the full 20 minutes diagnostic, much less, maybe 5 minutes) the sounds stop all together, i open the door and i see the third light (eco bio 50°) flashing, which i suppose is the test code, but i dont know the meaning.
Does anybody know what the meaning is and if i can fix the problem myself?
Thanks in advance.
 
Sponsored Links
Joined
20 Oct 2010
Messages
835
Reaction score
103
Country
United Kingdom
Might be better just to start checking/testing systematically starting with drain pump, waste hose / pipe / outlet / u bend etc... then move on to inlet valve,heater etc...
 
Joined
26 Jan 2016
Messages
4
Reaction score
0
Country
Italy
yes yardie, thanks for the answer, but im not very good/experienced in messing around with a dishwasher, having something to begin with would be helpful, and if i know what's the broad problem is, i can decide whether to call assistance or try to deal with myself.

What i dont understand is this:
im finding over the internet, and even here, the error codes for whirlpool dishwashers (F1, F2 etc), and they all involve the number of flashes of the start button light. One flash F1, two flashes F2 etc..

In my case i dont have that, after the diagnostic runs i get the third light flashing (the eco bio 50°), maybe that's because my machine is very old and meanwhile the codes changed? I got my dishwasher in 1999, and something tells me that maybe it's time to change it, then again it worked perfectly and i dont even use it that much, so if i can fix it with something easy/cheap that would be a plus, also considering i dont use it that much.
 
Joined
20 Oct 2010
Messages
835
Reaction score
103
Country
United Kingdom
Put a jug of water in the tub and start a programme, does it drain the water out?
 
Sponsored Links
Joined
26 Jan 2016
Messages
4
Reaction score
0
Country
Italy
yes it does drain the water.
This is another thing that happened: i wasnt at home for a period of time and i didn't even turn on the dishwasher for a while (after it started malfunctioning), the first time i tried again, after several days, i just reset the machine, started a normal program and it worked...albeit it stopped near the end of its program, alternate beeping, light on the rinse button, start flashing, the usual... the dishes were washed, the water drained, just a little bit of foam from the detergent remaining on the dishes, so i guess the program got until the rinse part and went on error for some reason.

After that, i tried again a few times to restart the program (by way of resetting) but it never worked again, as soon i close the door the machine starts beeping (alternate beeps), i open the door and i see the same error, rinse light on, start flashing.
 
Joined
20 Oct 2010
Messages
835
Reaction score
103
Country
United Kingdom
With the tub now empty start a programme, hold onto the inlet hose close to the inlet valve at the back of the machine, after draining has finished the water inlet valve should open and let in water, do you either feel the inlet hose jolt/flex as pressure is released or do you feel any vibrations on the hose to indicate the inlet valve is operating or attempting to open?

From your previous post it sounds like its either the heating element or the heating wiring circuit or possibly the heating relay.
 
Joined
3 Oct 2013
Messages
7
Reaction score
0
Location
Invernesshire
Country
United Kingdom
My machine did the same starts, pump runs, stays to beep and rinse light constant flashing with no code.

Run diagnostic and it runs fine and ends with eco program flashing

It turns out the water sensor (the black grill beside the ntc in the bottom of the tank inside the machine) was clogged with grease. The machine thought it was full of water all the time. I removed it, stripped and cleaned and all is working
 

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Sponsored Links
Top