Engine management light on 1998 corsa 1.0 12v

Joined
17 Jun 2010
Messages
7
Reaction score
0
Location
Cambridgeshire
Country
United Kingdom
My engine management light comes on in my corsa intermitaly when it feels like it ,sometimes from start up and does'nt go off or does then comes back on later and stays on. i do not get a drop in power and car runs like a turbo charged roller skate lol but it does have a low idle speed but does not stall. dont want to spend any money on it can anyone tell me what it might be?[/b]
 
Sponsored Links
Joined
7 Feb 2008
Messages
23,646
Reaction score
4,702
Location
Northumberland
Country
United Kingdom
More than likely to be the lambda sensor in the exhaust, if there is no loss of power. A garage with scanning equipment will be able to narrow things down and advise on what to do next.
John :)
 
Joined
17 Jun 2010
Messages
7
Reaction score
0
Location
Cambridgeshire
Country
United Kingdom
:D That reply sounds spot on ,have read up on lambda sensor and symptons match. but anyway do you think as i have no loss of power (except low idle speed) and fuel econemy is okay i can carry on running the car without replacing the sensor indefinatly or until mot in may 2011. Without doing any damage to the car.
Thanks Paul
 
Joined
7 Feb 2008
Messages
23,646
Reaction score
4,702
Location
Northumberland
Country
United Kingdom
It shouldn't do any harm mate - its not that unusual.
It seems to be the lambda sensors which have their own in built heaters that have this issue. I look after 2 Citroens that do this, and both get the MOT without any emission problems.
If the lamp is on continuously though, consider doing something about it.
John :)
 
Joined
17 Jun 2010
Messages
7
Reaction score
0
Location
Cambridgeshire
Country
United Kingdom
:D Thanks again, think i will keep running it without changing it for a while but consider replacing soon. I have some black tape which i will stick over the warning light which i feel is the way forward for now lmfao
 
Sponsored Links
Joined
2 Apr 2017
Messages
1
Reaction score
0
Country
United Kingdom
Hi there, I have just bought a Corsa b 1L 1999 model. The engine management light is illuminated and it sometimes has a flat spot on pull away in go. Anyone know what this could be? Really really hoping it's something simple as I have to get an mot done tomorrow!!!!
 
Joined
7 Feb 2008
Messages
23,646
Reaction score
4,702
Location
Northumberland
Country
United Kingdom
As the management lamp is on, this means that there is a fault code stored in the cars on board computer. This can be read by a garage with the appropriate diagnostics equipment, and they should be able to advise you what to do next. This will need to be sorted before an MOT certificate can be given, unfortunately. (Motman will know for sure.)
John :)
 
Joined
7 Feb 2011
Messages
103
Reaction score
8
Location
Sussex
Country
United Kingdom
had the same problem with my Vectra but each time I booked it in they were unable to locate a fault since when they switched the lamp off there was no light showing when they ran the engine but one of the fitters a Vectra owner pointed out that the cable had been routed to close to the exhaust and had frayed and was shorting the lambda sensor
 
Joined
27 Feb 2017
Messages
22,109
Reaction score
2,284
Location
Essexshire
Country
United Kingdom
An engine management light is not a failure (unlike, say, ABS, airbag, SRS etc) but it is an indication that it could fail on the emissions test.
 
Sponsored Links
Top