Ford Escort Finesse (1999) clutch

L

leeppp222

A couple of months back, my clutch went, so got it replaced. Then, not long after this, I started noticing a "grinding" sound when pulling away in 1st gear which got loader if you were pulling away slowing / up hills etc. Also, when you changed gears, there was a "clicking" sort of feel in the pedal - as if it was catching on something.

I took it back to the mechnic thinking it was the clutch but he said it was the cable (as he listened to it before starting the car by pumping the clutch up and down). I got this replaced and everything seemed ok.

However, today, this clicking feeling has come back in the pedal. Although it doesn't affect the driving etc, it just doesn't feel comfortable. The best way I can describe it is that it feels like the pedal is catching / rubbing on something.

Does anyone have any ideas what this could be as it's driving me MAD!!!
 
Sponsored Links
Joined
26 Feb 2006
Messages
96
Reaction score
0
Country
United Kingdom
Sounds like your clutch cable could be getting frayed or that it's not correctly connected to either pedal or gearbox. It could also be the thrust bearing. That makes a thrumming noise when it's under strain but isn't a major problem. Sounds like a bit of both to me.
 
Joined
30 Dec 2003
Messages
166
Reaction score
2
Location
Worcestershire
Country
United Kingdom
Check the obvious things first - the clutch/pedal linkage to determine where the 'lumpy' movement is coming from:
Put one hand on the clutch pedal lever and depress the pedal with the other hand - can you feel a smooth movement ?
Get a friend to depress the clutch pedal whilst you are under the bonnet/car feeling the actuating arm - smooth movement ?
Check cable mountings.
If its not 'on the way to the clutch' it must be the clutch itself - back to the mechanic.
 
Sponsored Links
Top