How do I remove a Danfoss Radiator Valve?

3 Mar 2006
Reaction score
United Kingdom
Can someone please tell me how to do this! The pin in the valve has stuck which means we have one cold radiator. The rad had been bled of air so we know that the problem is with the TRV. I am having difficulty removing the valve cover on the left side of the radiator to gain access to the pin for cleaning & greasing. The small black locking pin has been removed from the valve by the way! Thanks from a persistent lady DIYer. :(
Sponsored Links
You have to twist the innermost black, knurled section in the opposite direction to the main body of the head - difficult to explain in words, but imagine you're wringing the neck of a chicken - this will release the clamping bits inside the black section.

When you've finally managed that, read the bit on sticking TRVs in the FAQ topic, otherwise you'll do the wrong thing with the pin which you think is stuck (it probably isn't!).
They have a little locking tab in the black ring aswell, you need to lever this out unless it has already been broken off....most have.
hey, i've got the problem as well but i haven't managed to remove any of it yet, does anyone know how to remove the cover?

Sponsored Links
Iv been reading this post.. An i noticed you mentioned you have to twist the black bit of the body to release the thermostat.. These are exactly the same as my valves.. How ever one has broken... What are the valves called and will i be able to still get one? Tom
Lots of talk about removing the whole thing to get the pin to unstick. Have to say that I find a really aggressive wiggle and a couple of sharp taps often works. Just done it now. From cold radiator to warm radiator in 2 minutes.
I've 'manipulated' quite a few stuck pins over the years, with great success.
I have the same problem - a stuck pin ( I think).
Could someone please detail which tabs have to be removed before the top will come off, and the best way to remove them?
Can the tops be refitted properly even after the tabs have been released, or are the tabs then useless?
this post has been going since 2006, just set the head to max then turn the black part anti-clockwise about 1/4 of a turn and the sensor will pop off, when re-fitting you turn the same black part till it clicks then when you pop the head back on it will release and lock itself back on
Many thanks Ian. I did realise it was an old thread, but it was still relevant to my query, so I hoped people who helped before might clarify things for me.
As it happens, I only had to unscrew the dark grey collar underneath the white body, which I was then able to wiggle off. There were no tabs on mine.
The pin appeared to be stuck, and I was unable to get it moving but, bizarrely, the radiator began to heat up while I was still fiddling about with it when my wife turned up the main room thermostat downstairs.
I don't know what caused it to come on, as I hadn't touched anything else.
Any ideas please?
that is the problem with resurrecting an old thread, you have the newer style valve that the one that everyone was referring to, get some WD40 or equivalent and spray on the small pin, push it in and out many times with anything you like just to exercise the pin , spray some WD40 inside the sensor head and again move it from closed to open many times to free them up and then refit the head and all should be fine
Thanks Ian but, as I said earlier, I have been unable to get the pin moving. I have tried twisting it gently with pliers, prising it gently upwards etc, but no movement. That is why I was surprised when the heat suddenly started to come through. I would guess that the pin is locked in the open position, as I cannot close down the TRV when I replace the top cover.
I had already sprayed WD40 onto and around the pin. Unless I can get it moving tomorrow, when the WD40 should have penetrated right down, I guess it will need a new TRV.
Could it have been air in the system that prevented the rad from heating up, and it has possibly now dispersed?
the movement on the pin is miniscule , do not grab the pin or you will knacker it , just gently push it in and let it spring out , you are talking about 2-3mm at most , the fact that removing the sensor has brought the rad on is telling you that the valve is fine everything has just been sticking
I still can't see any movement of the pin Ian - not even 1mm - nothing at all.
With the body of the TRV off, and held in my hand, I can turn the dial clockwise from max down to *, but I have to push down on the dial (and there is a resisting clicking) to turn it finally to "0".
I have just tried turning the TRV dials on two rads in the adjoining rooms, and they turn back to "0" with no problem, no clicking and no pushing down needed.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links