Immersion heater not working past timer

Joined
18 May 2010
Messages
98
Reaction score
1
Location
Sussex
Country
United Kingdom
Can you guys offer some help please. Im sure the timer is the issue but the display is showing thats its all working.

Immersion heater timer is a Timeguard FST 11A
Power to the timer
No power to immersion heater with timer switched on
Fuse in the timer is is showing continuity
240 volts power the supply side of timer
0 volts at load side with timer switched on
With timer overide set to boost there is no power at the element
There is continuity when tested at the elements and showing 20 ohms.

Even though the timer display is all lit up and showing that its all working would you say that the timer is actually not working?
 
Sponsored Links
Joined
18 May 2010
Messages
98
Reaction score
1
Location
Sussex
Country
United Kingdom
Fluke T5 voltage / continuity tester

Not sure what you mean with the second question
 
Sponsored Links
Joined
18 May 2010
Messages
98
Reaction score
1
Location
Sussex
Country
United Kingdom
I think that too. Perhaps the display is working off the internal battery but the internal connections of the timer have had it.
I will stick an FCU in its place as a temporary measure to get some hot water and get a new timer tomorrow. Thanks for your input.
 

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Sponsored Links
Top