Mira Event XS Thermostatic not coming on?

Joined
29 Mar 2015
Messages
3
Reaction score
1
Location
Berkshire
Country
United Kingdom
Hi,

I have a Mira Event XS Thermostatic power shower and was working fine yesterday but now does not work.

When I press the on button I can hear a clicking noise but the light does not come on and the shower does not start.
Fuse in isolation box seems ok.

Could it be pcb or something else?

any help would be much appreciated.
 
Joined
30 Jun 2009
Messages
21,627
Reaction score
2,567
Location
Londonderry
Country
United Kingdom
It could be a number of things.
Firstly you want to confirm that electrical power is getting to the shower, then check water is.

If these are confirmed could be PCB, micro switch, thermal cut-out issue or the potentiometer.

How old is it?
 
Sponsored Links
Joined
29 Mar 2015
Messages
3
Reaction score
1
Location
Berkshire
Country
United Kingdom
Hi,

Thanks for the feedback.

I opened up the Shower unit and all seemed ok in there and then noticed the 2in extension plastic bit for the on/off button had broken off the cover.

Fixed that back on with silicone for now.
Problem all sorted!
 
L

longdogs

Hi,

Thanks for the feedback.

I opened up the Shower unit and all seemed ok in there and then noticed the 2in extension plastic bit for the on/off button had broken off the cover.

Fixed that back on with silicone for now.
Problem all sorted!

Ah yes, sorry, I should have twigged. had exactly the same problem a few months back with the same model. Maybe you bought the one I sent back. Did you buy it from Screwfix by any chance?
 
Sponsored Links
Top