Rollertech Garage Door will not go down

29 Feb 2012
Reaction score
United Kingdom
I have a rollertech remote control garage door, which will not go down.

It will open from the key fob and button on the control panel, however if you press the button on the key fob to go down it will click but not move.

If I keep the down button de-pressed on the control panel, it will go all the way down and lock.

If I do the same with the key fob it will go partially down and stop. indicating that the door is between the upper and lower sensors.

I have replaced the wireless transmitter batteries but this did not resolve it.

I have just acquired the installation guide for the Rollertech and it has a commissioning section which I plan to work through.

Any advice would be appreciated.

Sponsored Links
I have had similar trouble with my roller door (not the same model though) changed batteries pushed buttons etc.
Strangely both times the old "turn it off and on again" IT solution has worked. I unplugged it from the mains left it a couple of mins and plugged it in again!
Hi Footprints, thanks for the reply, I tried that as my first port of call.

Then replaced the batteries, and tried again.

Haven't had a chance yet to work through the commissioning part of the installation manual.

Failing that I guess I'll need to call someone out.
I am guessing it uses some magnets on the frame at the top and bottom. Are these still attached and flush?
Sponsored Links
Yea, it's got magnets top and bottom on the frame and a wireless transmitter on the door. Changed batteries and it flashes when it passed the magnets.
Does it have a safety edge at the bottom? Sometimes they become compacted and worn.
It does have a safety strip on the bottom. I think if that gets triggered the light flashes a sequence of colours to identify what triggered the stop/error. And it isn't showing any error codes at the moment.
If it moves up okay it isn't likely to be the motor.
If it moves down on a continuous press there ain't anything jammed or not working.
It will either be a problem with the transmitter needing the commissioning sequence completing (usually there is a button you press and hold for 5 seconds), the magnets are not being picked up correctly, or the safety edge is damaged and triggering.
Hi Tdw, that is more or less my understanding.

I'm going to power off and back on, clean the sensor strip, check the connection of the strip to the Transmitter.

Remove cover to access the commissioning button and carry out the commissioning sequence.

Give up

I've already had the motor fail and replaced. This is the second fault in approximately 5 years.

Started commissioning sequence. My understanding is that the door should have traveled, from the fully open position, to just below the 1st magnet. However the door traveled all the way down to just above the 2nd magnet, the control panel then gave a long beep to indicated that the commissioning sequence had failed. I was then going to check that the edge strip had been paired with the control panel. On opening the door, to get better access, the door opened all the way up and the sensor strip transmitter was partially covered by the roller cover, I pressed the button on the control panel to lower the door slightly, I did not expect the door to move as that was the fault. However the door fully closed.

I tested it again and everything seems to be working, good job well done!
Funnily I have exactly the same problem with Rollertech V5. But, I do not have the safety edge anymore as I now have a PEEC instead. Everything is working ok except I have to hold the button to close.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links