Salamander pump fault lights

Joined
22 Mar 2009
Messages
106
Reaction score
0
Location
Surrey
Country
United Kingdom
C54384A8-1BEC-4C65-BBF8-D09FD3F944C8.jpeg
So have these fault lights on my pump and was working great for years but now this has happened? Is there a fix for this I can do or is it a dead pump

many thanks
 
Sponsored Links
Joined
6 May 2010
Messages
1,605
Reaction score
604
Location
London
Country
United Kingdom
1. What model of Salamander pump?
2. Probably needs air pumping into the vessel marked "20 PSI", instructions should say.
 
Joined
22 Mar 2009
Messages
106
Reaction score
0
Location
Surrey
Country
United Kingdom
Thanks for reply

All sorted


Complete an air test!
Follow these instructions to remove air from your pump installation.

1. Turn off pump.

2. Remove shower head from hose.

3. Let hose hang into bath or shower tray.

4. Turn the temperature to full cold.

5. Turn the shower on and run for 5 minutes.

6. Turn the temperature to full hot and run for a further 5 minutes.

7. Turn off the shower.

And it worked! So all good

Hope this helps somebody else with the same problem
 

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Sponsored Links
Top