Servis Washer Easi Logic 1600 Fault

Joined
13 Sep 2014
Messages
4
Reaction score
0
Location
Nottinghamshire
Country
United Kingdom
Hello can anyone give me some advice on this fault please. On a 40/50oC cycle the washer fills with water (not completely) water heats up but drum doesn't revolve, pump removes water, then it doesn't refill with water to rinse, doesn't spin, programme ends & switches off after a few minutes on a wash cycle which normally would take 1hour 40 mins. Somebody suggested it may be the PCB which is expensive. Can anyone help me please? Thank you
 
Sponsored Links
Joined
1 Dec 2006
Messages
5,343
Reaction score
521
Location
Cumbria
Country
United Kingdom
Drive belt & motor brushes would be the first things I would look at.
 
Joined
13 Sep 2014
Messages
4
Reaction score
0
Location
Nottinghamshire
Country
United Kingdom
Drive belt & motor brushes would be the first things I would look at.

Thanks for your quick reply, however when use spin mode on program switch it will spin normally, which indicated that the pcb could be faulty as its not cycling through the selected program, but I will check this a let you know thanks.
 

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Sponsored Links
Top