Thorn apollo 15/30b Help

Joined
7 Jun 2006
Messages
191
Reaction score
3
Location
London
Country
United Kingdom
Hi All
Just turned on my boiler via 3 amp fused switch and heard a pop and saw a little smoke beside the control/wiring harness.

Changed the fuse and lit pilot all ok, the boiler fired and heating started coming on, pump working , turned the hot water stat on cylinder to zero and the heating down to 10.

Re lit boiler and it fired up straight away, it only stops firing when I turn the programmer off.
I can turn the grey knob on the gas valve and it will shut off as it should.

Could not see any damage to wiring harness or contacts nor any sign of burnt areas,
Is thera a circuit board under the electrical connectors?

Could the hi low thermostat switch have failed allowing the boiler to permanently fire up.

Any advice would be truly appreciated.
 
Joined
7 Jun 2006
Messages
191
Reaction score
3
Location
London
Country
United Kingdom
Hi All

Quick update, the suppressor is at fault, it failed, on closer inspection, it even blew the plastic cover off.

Ordered a new one today, will fit tommorrow, my qustion is do these affect any other parts on the wiring system as the 3 amp fuse did not even blow? Like I said the boiler fired up, pump running, no visual damage elswhere, is the suppressor failure a common fault?

Regards
 
Sponsored Links
Joined
1 Jul 2007
Messages
56,034
Reaction score
9,554
Location
Hertfordshire & London
Country
United Kingdom
upload_2017-10-23_20-43-40.png
 
Sponsored Links
Top