Triton Ivory 2 Electric Shower, hot for 2 secs then cold

Joined
8 May 2012
Messages
88
Reaction score
0
Location
Durham
Country
United Kingdom
Hi

I have a Triton Ivory 2 (10.5 I think) shower which has recently stopped working properly.

It basically runs hot for a few seconds then runs cold. Tried cleaning it, turning the dials and nothing. Just had the front off but nothing seems to have blown or corroded.

As I acquired it when I bought the house I've no idea how old it is, but it has been a cracking little shower to date.

Before I go out and spend a £100 quid plus on a new one I wonder if anyone could tell me what is wrong with it and what part is likely to need replaced so I can price it up.

Here's some pictures.

F6EDFEA7-88CD-4033-AEF8-C25FEC4F1E4A-5725-000003ED043B5664_zpseff6033d.jpg


66B5BD1D-92E8-4232-BD44-E130552B4DF4-5725-000003ECF43E0B71_zps14770d6d.jpg


Thanks

Jacka
 
Sponsored Links
Joined
16 Oct 2012
Messages
379
Reaction score
76
Location
Gwynedd
Country
United Kingdom
Unscrew the shower head and see if same thing happens also check if there is a filter that could be blocked.
 
Joined
8 May 2012
Messages
88
Reaction score
0
Location
Durham
Country
United Kingdom
I tried that earlier and it made no difference at all.

I had a look when I had the cover off but there didn't appear to be any kind of filter inside
 
Joined
3 Dec 2007
Messages
15,701
Reaction score
1,328
Location
Essex
Country
United Kingdom
Can be your hose collapsing internally.
your inlet filter blocked.
your stopcock/isolation valve not fully open.
 
Joined
8 May 2012
Messages
88
Reaction score
0
Location
Durham
Country
United Kingdom
The guide above was for the wrong shower but found the right one after a little search.

Checked the filter, but that was clear and to be honest the pressure is really good on it. It's worked quite well since last year but all of a sudden stopped.
 
Joined
8 May 2012
Messages
88
Reaction score
0
Location
Durham
Country
United Kingdom
Given the fact the pressure is good and not reducing at all, what else could it be?

Regarding the hose, do you mean the shower hose? or something internal?
 
Sponsored Links
Joined
8 May 2012
Messages
88
Reaction score
0
Location
Durham
Country
United Kingdom
It's defo not the hose.

The dial is always on max (10). Read a few other posts of people saying the same about that model
 
Joined
3 Dec 2007
Messages
15,701
Reaction score
1,328
Location
Essex
Country
United Kingdom
It's defo not the hose.

The dial is always on max (10). Read a few other posts of people saying the same about that model

Should never need it on 10 even this time of yr.
8 is useally high enough even in winter.

And 10 will only barely be a fast trickle.
 
Joined
8 May 2012
Messages
88
Reaction score
0
Location
Durham
Country
United Kingdom
http://www.screwfix.com/p/triton-enrich-electric-shower-8-5kw/52753

£75 from screwfix will fit. same shower different name it only has 6mm cable so it shouldn't be 10.5kw

Didn't even look a the cable size. Thanks for bringing that up.

Will buy one of those showers at the weekend. Will a 6mm cable be ok for that shower? The length is probably no more the 7/8 metres and that's playing it safe.

Thanks again

Jacka
 
Joined
8 May 2012
Messages
88
Reaction score
0
Location
Durham
Country
United Kingdom
As far as I can tell I have a 32mcb on the fuse board.

The shower is in the main bathroom which we don't use as we have an en-suite and. I'm only replacing it because we have a few people coming to stay in 3 weeks, so it won't be used regularly. at least not until our little boy gets older (only 6 months).
 
Sponsored Links
Top