Underfloor Heating problem

Joined
7 Dec 2003
Messages
52
Reaction score
0
Country
United Kingdom
Hi,

Could some help please. I have a 10 year old water underfloor heating system (JG Speedfit kit) which has been working well until last week. The system is connected to the boiler and is also linked to the hot water and central heating system.

When the hot water or central heating comes on, the UW pump runs and hot water goes into the underfloor system, even of the UW thermostat is off. The UW pump goes off when hot water or CH switches off. Any thoughts on what this could be? I was wonder if one of the valves near the hot water tank was stuck or whether it's something else. Just a bit worried that if I call someone in they might insist the whole manifold system needs changing when it may be something else.

Thanks in advance
 
Last edited:
Joined
7 Dec 2003
Messages
52
Reaction score
0
Country
United Kingdom
Please let me know if I can provide any other information to help. Alternatively, if someone can recommend a UFH (water) repair specialist in the West Midlands, that would be great. Thanks.
 
Sponsored Links
Joined
28 Oct 2005
Messages
13,548
Reaction score
3,189
Location
Daventry
Country
United Kingdom
So are you saying that your UFH comes on even when it's supposed to be turned off? As in the floor gets warm? Can you post a photo of your manifold?
 
Joined
7 Dec 2003
Messages
52
Reaction score
0
Country
United Kingdom
That's right, even with the UFH thermostat turned right down, the UFH comes on when the Central Heating or Hot Water comes on. I can send a picture of the manifold later, but I've attached a picture of the kit used. Thanks
IMG_20171204_080738_01.jpg
 
Sponsored Links
Top