Vailliant boiler issue (S.O -Heating issue, no heat demand)

Joined
11 Jan 2020
Messages
4
Reaction score
0
Country
United Kingdom
Hello,

My Vailliant boiler was showing F.27 (incorrect sensing of flames). I opened the panel and replaced the 2A fuse. After that the boiler stopped responding. Status code now is S.O (Heating issue, no heat demand). Does not respond to opening hot water tap or turning on the radiator. Pressure is at 1.0bar. Appreciate any advice.

Pavlos
 
Last edited:
Sponsored Links
Joined
15 Nov 2005
Messages
77,166
Reaction score
4,790
Location
Crossgates, Europe
Country
Cook Islands
you say you replaced a fuse. Did you find out what was the fault that caused the fuse to blow?
 
Joined
11 Jan 2020
Messages
4
Reaction score
0
Country
United Kingdom
Hi JohnD thank you for responding. No I did not - I do not know whether it blew or not. I only have a screwdriver as a tool. From what I saw on the internet the cause of f27 is probably a faulty igniter or a component of the board. Having no way to check whether the components were working i just replaced the fuse as a first step.
 

CBW

Joined
26 Sep 2019
Messages
11,665
Reaction score
3,259
Location
North
Country
United Kingdom
Pavlos,

If this is a combi boiler (sounds likely) then you will need a registered gas engineer to remove the cover and repair the fault. A gas appliance is also classed as a gas fitting, which you need to be competent to work on, and undertake any relevant gas safety checks afterwards. F27 is a relatively easy fix.
 
Joined
11 Jan 2020
Messages
4
Reaction score
0
Country
United Kingdom
'Engineer' came and he was useless. I had to direct him towards looking at the board, he agreed that that was the issue and that he needed £200 to replace it (he charged me £120 for the visit). I asked him if he could check individual components of the board to see which was faulty and said he couldn't. I don't want to pay £120 for a guy to come and tell me that the board is faulty - which i already deduced.

Can anyone help me please? Further issue which he didn't notice is that the screen is showing me 1.0bar, whilst the analogue meter shows well above 1.0bar.

Any advice is appreciated!
 
Joined
11 Jan 2020
Messages
4
Reaction score
0
Country
United Kingdom
To recap.

F27 (incorrect sensing of flames) issue showing on the screen.
Changed fuse.
Boiler turns unresponsive.
S.0 (Heating issue, no heat demand) when i press 'I'
screen showing different pressure reading than analogue meter (analogue shows high pressure) - im not sure when this happened.
 
Sponsored Links
Top