Water Softener Salt Blocks not going down

Joined
27 Jan 2014
Messages
16
Reaction score
0
Location
London
Country
United Kingdom
Hi.
I have a Harvey Arc water softener which takes blocks of salt and I have noticed over the past week that salt has remained the same and not gone down. Limescale has also starting to appear around the taps and sink so it looks like it's stopped working.
I have a bypass valve to use when watering the garden but that is definitely not switched on so not sure what else is causing it to stop working.
The Softener is non electric and I have a RO drinking tap as well.
I have called Harvey's to book an engineer out but it will take a week for them to come out.
Any obvious troubleshooting I can do?
I tried removing the salt blocks from the unit to check for any blockages but can only see a some water at the bottom. Not sure if the water there means something is blocked?
Thanks
 

Attachments

  • IMG_20220609_190742.jpg
    IMG_20220609_190742.jpg
    243.7 KB · Views: 39
  • IMG_20220609_190636.jpg
    IMG_20220609_190636.jpg
    120.2 KB · Views: 38
Sponsored Links
Joined
14 Apr 2017
Messages
164
Reaction score
28
Country
United Kingdom
Do you ever hear it regen? I've got a monarch twin softener and regularly hear it run.
 
Joined
14 Apr 2017
Messages
164
Reaction score
28
Country
United Kingdom
It's meant to regen when one cylinder is exhausted. Check the flow meter wheel is rotating when a tap is run
 
Sponsored Links

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Top