Windscreen wiper problem

Joined
21 Feb 2021
Messages
4
Reaction score
0
Country
United Kingdom
I have a Nissan Micra K12,2003. Lately it developed a fault which front screen wiper starts as soon as I start the engine. This happens when there is moisture around. It runs 5 to 7 minutes and than stopes. It does not do this in dry weather. I disconnected the moisture sensor but still does it.
I'll appreciate any suggestion/ideas. thanks in advance.
kamer
 
Sponsored Links
Joined
31 Oct 2019
Messages
1,423
Reaction score
224
Country
United Kingdom
Moisture in air bridging electrical connection somewhere?

Goto town with wd40 , that would be my first port of call
 
Joined
7 Feb 2008
Messages
23,646
Reaction score
4,702
Location
Northumberland
Country
United Kingdom
If the wipers are switched off when this happens, I’d look at the self park mechanism- that is live all of the time.
John :)
 
Joined
21 Feb 2021
Messages
4
Reaction score
0
Country
United Kingdom
If the wipers are switched off when this happens, I’d look at the self park mechanism- that is live all of the time.
John :)
Thanks John. Could you explain a bit more please? I don't know where the self park mechanism is. I took out pump fuse but it has no effect. When the engine warms up everything is normal.
Kramer
 
Joined
7 Feb 2008
Messages
23,646
Reaction score
4,702
Location
Northumberland
Country
United Kingdom
You'll notice when you turn the wipers off at the stalk, they move to the self park position (not when you turn the ignition off though)......this is because there is a live feed to the wiper motor and particularly the self park switches within.
Anyway, the Micra has a 'Body Control Module' (BCM) which controls such things like this - nothing is simple! I'd do some googling to see where it is, and then unplug its connections for a few minutes - much the same as disconnecting the battery for a while - although this will lose you the radio code.
Firms such as BBA- Reman or ecutesting.co.uk may be able to help.
John :)
 
Sponsored Links
Top