Worcester 280 RSF problem

Joined
1 Aug 2005
Messages
2
Reaction score
0
Location
Herefordshire
Country
United Kingdom
I switched off my Worcester 280 RSF and drained the radiators, then replaced the bathroom radiator. I then refilled the radiators and bled them. When I followed the operating instructions for relighting the boiler, the results weren't quite as I expected.

The instructions say to turn the temp control to max and set the operating switch to heating & water and the burner should light straight away. This doesn't happen. However, if I turn on a hot tap, the burner lights and after a short delay hot water runs out. When I switch the tap off though, the burner goes out and the reset switch on the boiler pops up. Thereafter I get no hot water.

Is there something obvious I've missed, or should I just get someone in to have a look?
 
Sponsored Links
Joined
24 Jul 2003
Messages
24,294
Reaction score
1,417
Location
London
Country
United Kingdom
First thought would be AIR trapped in it. Make sure the automatic air vent's cap is open a couple of turns
 
Joined
1 Aug 2005
Messages
2
Reaction score
0
Location
Herefordshire
Country
United Kingdom
Thanks Chris, but where is the air vent?.

I've also noticed that a few minutes after the reset button pops up, the boiler makes a horrible gurgling noise. Adding to your idea of there being air inside.
 
Sponsored Links

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Top