Worcester 532/i always 'on'

Joined
29 Nov 2007
Messages
58
Reaction score
2
Location
Staffordshire
Country
United Kingdom
Hi,

I've recently moved into a new home, which has a combi boiler (my first one) and it's a Worcester 532/i. Everything is working correctly, in that I can make the heating come on if I need it, and there's hot water in the taps.

The problem is, it's always making a noise even when the heating is off and no taps are being ran. My first theory was that it was constantly pre-heating water, so I've switched on Eco-mode, which I believe should stop this behaviour, but it's made no difference. I don't know what the boiler is doing, but whatever it is is doing, I figure it must be wasting energy?

The noise doesn't sound like a fault - no banging, clicking, whining etc. It's just a constant low level noise similar to when the heating is on - only much quiter.

Could anybody offer any suggestions on things to try/check?

EDIT: Forgot to mention that the bar pressure looks ok-ish - at just under 2 (about 1.8 at a guess)

Thanks
 
Last edited:
Sponsored Links
Joined
25 Jan 2010
Messages
368
Reaction score
95
Location
Bristol
Country
United Kingdom
normal Transformer hum so nothing to fix, but seeing as its getting close to winter why not get it serviced and put your mind at rest.
 
Joined
29 Nov 2007
Messages
58
Reaction score
2
Location
Staffordshire
Country
United Kingdom
Thanks both. Was concerned it might be the fan or the pump.
Will be setting up The Hive tomorrow (as previous owner left it). Hopefully that might show me the gas usage, and if not, will take some readings.
 
  • Like
Reactions: CBW
Sponsored Links
Joined
15 Aug 2010
Messages
26,831
Reaction score
13,435
Location
Livingston
Country
United Kingdom
Thanks both. Was concerned it might be the fan or the pump.
Will be setting up The Hive tomorrow (as previous owner left it). Hopefully that might show me the gas usage, and if not, will take some readings.
Hive cant show you gas usage, only your gas meter can do that
 
Joined
9 Sep 2005
Messages
12,769
Reaction score
3,495
Location
Sussex
Country
United Kingdom
This is a 20 year old boiler and the first generation condensing Worcester (AFAIR manufactured by Junkers/Bosch).
They were a great boiler but are now getting on.
The noise could be the pump continuously running, it's a known issue with these early DDPWM pumps.

A full and proper service (gaskets/electrodes etc.) will set you back almost £100 for the parts now (and that's trade price) and a good couple of hours labour. It's a slow laborious task and anything less and it's not a proper service.

The pressure should be around 1 to 1.5 bar with the radiators cold and ideally no more than 2 when hot.

AFAIR you can't connect anything except the Worcester TR2 thermostat.
Do a search on the forums as this issue has cropped up a no. of times.
 

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Top