Acer Aspire 5536 keyboard and touchpad problem

Discussion in 'Hardware' started by chippie244, 26 Mar 2010.

  1. chippie244

    Joined:
    2 Apr 2009
    Messages:
    177
    Thanks Received:
    19
    Location:
    Hertfordshire
    Country:
    United Kingdom
    My fairly new laptop's keyboard won't work when I first go on to it but if I restart it gives an error message 0211:keyboard error but pressing F1 gets it working for a while, the touchpad won't work at all.
    I have run Malawarebytes and AVG and they haven't found a problem and going into control panel it says the keyboard is fine, I can't find anything for the touchpad but that could be my ignorance.
    Not that clever on the internal workings of computer systems so any solutions along the lines of " go into BIOS and change command line" will need every little step laid out clearly.
    Cheers.
     
  2. Monkeh

    Joined:
    25 Jan 2010
    Messages:
    4,117
    Thanks Received:
    323
    Location:
    Cornwall
    Country:
    United Kingdom
    Sounds like a loose cable. If the laptop is new, get it fixed under warranty.
     
  3. unseen

    Joined:
    14 Nov 2006
    Messages:
    69
    Thanks Received:
    3
    Location:
    Manchester
    Country:
    United Kingdom
    From what you've described chippie it sounds like a loose connection internally, not as uncommon as it sounds... Had whole batches of HP "Elite" laptops come supplied to us like that.
    The thin ribbon cable that connects keyboard to laptop is only clipped into a connector removing the keyboard and reseating this cable usually fixes the problem (if not it's a warranty repair/replacement I'm afraid).

    This link is the service manual for your laptop

    If you download that PDF you need pages 57 - 61 which shows the sequence to remove the keyboard. Page 61 shows the connector you need to reseat the ribbon cable of the keyboard.

    Hope that helps!
    Rob
     
    • Thanks Thanks x 1
  4. chippie244

    Joined:
    2 Apr 2009
    Messages:
    177
    Thanks Received:
    19
    Location:
    Hertfordshire
    Country:
    United Kingdom
    Thanks a lot unseen and monkeh. I had seen the loose cable suggested on other forums but I couldn't see why it would work after a reboot.
    The laptop was an insurance replacement for one that was stolen so I've been in touch with the insurers and they're sorting it out.
    Once again, many thanks.
     
  5. Monkeh

    Joined:
    25 Jan 2010
    Messages:
    4,117
    Thanks Received:
    323
    Location:
    Cornwall
    Country:
    United Kingdom
    Thermal expansion, vibration, etc. There's a thanks button y'know. ;)
     
  6. chippie244

    Joined:
    2 Apr 2009
    Messages:
    177
    Thanks Received:
    19
    Location:
    Hertfordshire
    Country:
    United Kingdom
    The insurers suppliers told me to to do a restore by pressing F11 but as the keyboard didn't work it wasn't entirely successful :LOL: so they're taking it back.
    I know there must be a thanks button but I can't find it :oops:
     
  7. Monkeh

    Joined:
    25 Jan 2010
    Messages:
    4,117
    Thanks Received:
    323
    Location:
    Cornwall
    Country:
    United Kingdom
    Top right of each post.
     
    • Thanks Thanks x 1
  8. unseen

    Joined:
    14 Nov 2006
    Messages:
    69
    Thanks Received:
    3
    Location:
    Manchester
    Country:
    United Kingdom
    Gah... Typical! Almost as bad as our usual "Turn it off.. And turn it back on again" (only our advice usually works :LOL: ) Glad your getting it sorted though!
     

Share This Page