BEKO DWD4310W Dishwasher not working

Discussion in 'Appliances' started by citruspink, 14 Apr 2007.

  1. citruspink

    Joined:
    14 Apr 2007
    Messages:
    3
    Thanks Received:
    0
    Location:
    Kent
    Country:
    United Kingdom
    Hi.

    I have just bought a BEKO DWD4310W dishwasher which was installed yesterday.

    It doesn't seem to be working, there is power to it and if I press and hold the stop/start button it makes a sound as if it is draining water but when I turn the dial to the program I want to run (I have tried all) it makes a noise but nothing happens, I left it for a few hours earlier (incase it needed time to start) and still nothing is clean.

    Any ideas??

    Thanks
     
  2. jayzee

    Joined:
    22 Oct 2006
    Messages:
    42
    Thanks Received:
    0
    Country:
    United Kingdom
    Are you sure youve connected and turned on water supply
     
  3. citruspink

    Joined:
    14 Apr 2007
    Messages:
    3
    Thanks Received:
    0
    Location:
    Kent
    Country:
    United Kingdom
    I didn't install it the delivery guys did.

    I watched them put a pipe in the back of the machine but not sure if/how they switch/ed it on.

    would this be a plumbing question?
     
  4. Sleepyhead

    Joined:
    2 Apr 2006
    Messages:
    1,896
    Thanks Received:
    27
    Country:
    United Kingdom
    Why would you ask a plumbing question?
    Make sure the water is turned on to the machine, that the hoses haven't kinked when the m/c was put in place and also check the drain hose.
    If you find the delivery men haven't installed it properly and you've paid for installation, complain.
     
  5. citruspink

    Joined:
    14 Apr 2007
    Messages:
    3
    Thanks Received:
    0
    Location:
    Kent
    Country:
    United Kingdom
    Thank you Jayzee.

    I managed to get the machine out and the water supply indeed wasn't on. It now is and the machine is working fine. :D

    Sleepyhead... the reason I asked if it should be a plumbing question was because I read the rules to this forum and they say to only post questions in the correct area so "how to turn the water on :oops: " would be a plumbing question.
     
  6. Steve007

    Joined:
    4 Nov 2009
    Messages:
    1
    Thanks Received:
    0
    Location:
    Cambridgeshire
    Country:
    United Kingdom
    Hey guys sorry to bump this topic but I have exactly the same dishwasher (DWD4310w) and it sounds like exactly the same problem except I have had mine for three years and untill now it has worked fine. However now when I select the programme I want and press and hold the start button it makes the draining noise as mentioned but after 10 seconds the red light comes on for the end of the cycle. My water suply is On as I have tried reconnecting it all and it leaked water all over the place. I dont know how to check the drainage pipe if that is a possable answear, I have no idea what to do so any help will be greatly appreciated. Thanks in advance
     

Share This Page