1. We are pleased to announce the 'Home Automation' forum. Click here to get involved!

Central Heating Pump Runs Continuously

Discussion in 'Plumbing and Central Heating' started by JB1, 23 Jan 2010.

  1. JB1

    JB1

    Joined:
    23 Jan 2010
    Messages:
    4
    Thanks Received:
    0
    Location:
    Northamptonshire
    Country:
    United Kingdom
    Hi, Any ideas please. My central heating has been running fine up to about a week and half ago when the cold the cold weather hit. Now the CH pump will not shut down it runs 24x7 whether the heating is on or off. I've tried changing the frost stat ( The boiler is in the garage) the pump overrun stat on the boiler and the overheat stat on the boiler and the thing keeps on running. Any ideas?
    The pump is a grundfoss and the boiler is a Potterton Netaheat Profile 80e.

    The CH and HW are working fine and the boiler works fine when the timer kicks in.

    Help!!!
     
  2. tomy

    Joined:
    19 Aug 2005
    Messages:
    379
    Thanks Received:
    15
    Location:
    Cheshire
    Country:
    United Kingdom
    Two port or three port valve is faulty
     
  3. JB1

    JB1

    Joined:
    23 Jan 2010
    Messages:
    4
    Thanks Received:
    0
    Location:
    Northamptonshire
    Country:
    United Kingdom
    Yep I thought that might be the case. But when I turn off the CH and the HW independantly. They both activate.
     
  4. Corgigrouch

    Joined:
    13 Dec 2007
    Messages:
    3,600
    Thanks Received:
    424
    Country:
    United Kingdom
    Which boiler is it?
     
  5. JB1

    JB1

    Joined:
    23 Jan 2010
    Messages:
    4
    Thanks Received:
    0
    Location:
    Northamptonshire
    Country:
    United Kingdom
    the boiler is a Potterton Netaheat Profile 80e.
     
  6. gas112

    Joined:
    27 Oct 2009
    Messages:
    9,428
    Thanks Received:
    2,379
    Country:
    United Kingdom
    Does the boiler boiler fire up as well every so often if so its microswitch in motorised valve.
    If it doesnt it will be the pump over run stat in boiler at fault
     
  7. steve32

    Joined:
    23 Nov 2008
    Messages:
    579
    Thanks Received:
    93
    Location:
    Essex
    Country:
    United Kingdom
    micro switch in the mv is stuck on
    you may be able to free it or replace head
     
  8. JB1

    JB1

    Joined:
    23 Jan 2010
    Messages:
    4
    Thanks Received:
    0
    Location:
    Northamptonshire
    Country:
    United Kingdom
    Ok so which one or both MV's do I change. The system has 2 x 2port MV's fitted. I've had a play this morning and they seem to be working ok but the HW MV was sticky. Pump is still running with the system off. Also the boiler does cut in intermittantly when the HW and CH is turned off on the timer.
     
  9. tomy

    Joined:
    19 Aug 2005
    Messages:
    379
    Thanks Received:
    15
    Location:
    Cheshire
    Country:
    United Kingdom
    check the wiring to see which one or maybe both will feed the boiler then disconect and test with a multimeter to see which valve is supplying 240v to the boiler when it shouldnt be.
     

Share This Page