iveco daily 35s12

Discussion in 'General Cars' started by dpsservices, 11 Mar 2010.

  1. dpsservices

    Joined:
    22 Dec 2008
    Messages:
    336
    Thanks Received:
    6
    Location:
    Northamptonshire
    Country:
    United Kingdom
    just had the cam belt changed on my 35s12 03 plate iveco. now the mechanic that done the job says that the bottom crank was one tooth out when he started it as it sounded to lean so he stripped it back down altered it and fired it back up. now ive been out to collect the van and it does sound ok but and a big but the red injector light is flashing which means its in limp mode and will not rev past 3000. now the mechanic is saying all is well it has picked up the fault from when he first started it and all I need to do now is get the code cleared. now for one does what he says make sense and second why should i have to pay to get the code read and cleared, but if i do anyone got an idea on the cost cheers in advance its been a long day and im now off to bed in a very pi**ed off mood. any and i mean ANY input would be much appreciated cheers mates
     
  2. ch427

    Joined:
    16 Jan 2006
    Messages:
    2,537
    Thanks Received:
    238
    Location:
    Cardiff
    Country:
    United Kingdom
    did you have the timing belt changed as a maintainence job or for another reason?
    how was the van before the mechanic started work on it?
     
  3. dpsservices

    Joined:
    22 Dec 2008
    Messages:
    336
    Thanks Received:
    6
    Location:
    Northamptonshire
    Country:
    United Kingdom
    all sorted now just bought van and have no history of when it was done last so got it changed. spanner man miss timed it by 1 tooth on the crank, he stripped it all today and sorted it, pulling like a train again. must admit this has been a nightmare to start with costing me alot of money. hope all goes well from now on
     
  4. Nordio

    Joined:
    17 Mar 2010
    Messages:
    101
    Thanks Received:
    0
    Country:
    United Kingdom
    Hmmn interesting.
     
  5. dpsservices

    Joined:
    22 Dec 2008
    Messages:
    336
    Thanks Received:
    6
    Location:
    Northamptonshire
    Country:
    United Kingdom
    :confused: in what way?
     
  6. vauxbeem

    Joined:
    5 Jun 2010
    Messages:
    1
    Thanks Received:
    0
    Location:
    Ayrshire
    Country:
    United Kingdom
    hi injector light flashin and starts then stops no fuel at filter bleed screw when ignition on does it have pump in tank its an 05 reg
     
  7. dpsservices

    Joined:
    22 Dec 2008
    Messages:
    336
    Thanks Received:
    6
    Location:
    Northamptonshire
    Country:
    United Kingdom
    should have pump on chassy rail when you switch ignition on you should hear it buzz for about 15 seconds if not gently tap it with something hard ;)
     

Share This Page