Mira shower no hot water

Discussion in 'Plumbing and Central Heating' started by davphi338, 22 Dec 2006.

  1. davphi338

    Joined:
    13 Feb 2005
    Messages:
    235
    Thanks Received:
    0
    Country:
    United Kingdom
    Hi,

    I have a Mira shower that has suddenly decided not to give any hotwater. The shower is connected to a shower pump but I know the pump is OK because the shower in the ensuite is OK and it connects to the same pump.

    The pump comes on when the temp is set to cold and there is water flow but when I move the temp to anything but cold there is no water flow at all.

    Is there anything I can do to the shower to rectify this fault or is it beyond repair.
     
  2. leakydave

    Joined:
    2 Nov 2005
    Messages:
    788
    Thanks Received:
    72
    Location:
    Gloucestershire
    Country:
    United Kingdom
    what sort of 'Mira' shower is it?
     
  3. peo11

    Joined:
    30 Dec 2006
    Messages:
    2
    Thanks Received:
    0
    Location:
    Wiltshire
    Country:
    United Kingdom
    Believe it or not my mira shower has developed the same fault.
    I have a mira 88 mixer valve.
    I know that there is a seal kit available but how do you get the front plate off the mixer valve?
     
  4. davphi338

    Joined:
    13 Feb 2005
    Messages:
    235
    Thanks Received:
    0
    Country:
    United Kingdom
    Mine was a Mira Excel, I took it apart as much as possible but the actual valve unit seemed to be a sealed unit.

    I installed a cheapo replacement to get the shower working until I renovate the bathroom properly.
     
  5. peo11

    Joined:
    30 Dec 2006
    Messages:
    2
    Thanks Received:
    0
    Location:
    Wiltshire
    Country:
    United Kingdom
    Decided to bite the bullet and try to fix the problem.
    Seal kit obtained from plumbase.
    Had already obtained replacement instructions direct from Mira (visit their website, very helpful people).
    Needed heat to get cover assembly off along with large stilson wrench and a hammer.
    Replaced all seals and put it all back together and guess what? still no hot water coming out when shower head lifted up.
    Needed to replace seals anyway as there was a leak.
    Removed shower head and held hose in the air, hot water came out when fully hot selected. Cleaned shower head holes with a pin. Tried again, hot water Hurray :p :p :p

    Tried shower myself first in case of any problems, felt great.
    Hope this may help any readers.

    Peo11
     
  6. bab

    bab

    Joined:
    31 Dec 2005
    Messages:
    873
    Thanks Received:
    7
    Location:
    Lancashire
    Country:
    United Kingdom
    Dont think ya can do much with em except replace. would check water flow out of body with cartridge out 1st to elininate no supply. u never no might be a check valve somewhere. is there 1 on the cartridge inlet. (white ball)
     
  7. soul-man

    Joined:
    28 Oct 2007
    Messages:
    4
    Thanks Received:
    0
    Location:
    London
    Country:
    United Kingdom
    I have been struggling with this problem for many months. Talking to Mira techies and getting nowhere.

    Here is the answer though.

    I was advised to check the strainers to see that they were clean and clear to allow the water to flow. These are located in front of two checkvalves situated on the Mira Aquations unit at the bottom at each side. Undone by a largish allen key, these checkvalves have the strainers delicately held in place by rubber seals at their tip. However it was not the strainers that were at fault but the checkvalves themselves, these were stuck closed. It was this that made my Mira shower fail to function not the strainers.

    It would seem that not even Mira knew of this problem and I think this may be a design fault.

    I do hope this of some assistance in the future.
    Soul-man
     

Share This Page