Recent content by ross sears

  1. R

    Danfoss tp5000si thermostat display problems

    Brilliant thanks, so whats the solution please?
  2. R

    Danfoss tp5000si thermostat display problems

    Ah ok, my house is a new build so maybe got installed because it’s cheap? So whats the solution? Get the boiler serviced and then it will be ok?
  3. R

    Danfoss tp5000si thermostat display problems

    So i’m quite confused now, as i pulled the thermostat off the wall and it was still on, but had a 4core power cable going to it also. So are the batteries just a back up? Also I didn’t see any low voltage cables so does this mean it’s a wireless unit? Where would i find the receiver?
  4. R

    Danfoss tp5000si thermostat display problems

    It doesn’t say anything about it, I can’t find any troubleshooting information anywhere! I think it’s wired not the system but not powered by it, because when i turn the mains off to the heating system the thermo is still on.
  5. R

    Danfoss tp5000si thermostat display problems

    Ok thanks for the info, didn’t know that. I changed for normal alkaline and still jo result
  6. R

    Danfoss tp5000si thermostat display problems

    Changed for good alkaline batteries, still the same issue.
  7. R

    Danfoss tp5000si thermostat display problems

    I put rechargeable ones in. Bad idea? Going to look for good batteries, although the low battery symbol never appeared.
  8. R

    Danfoss tp5000si thermostat display problems

    Going to shut the whole system down for 10 minutes see if the issue resolves
  9. R

    Danfoss tp5000si thermostat display problems

    My Danfoss tp5000si display has all of a sudden stopped displaying the time and intstead shows only 2 dots flashing where the time normally is and also the temperature, which when i first looked was down at 5c. I moved to temp upto normal 20c and it switched on and the heating came on as normal...
  10. R

    Danfoss Tp5000si thermostat display

    Did you manage to find out the issue? As i am having that problem right now. Thanks
Top