Recent content by stevo518

  1. Untitled

    Untitled

  2. stevo518

    stevo518

    my pics
  3. S

    vivaro van speedo stopped working

    cheers man..just my rotten luck!!
  4. S

    vivaro van speedo stopped working

    Hi fellas The speedo started jumping about a few weeks ago,now its stopped working altogether. I believe it could be a sensor or wiring problem,is anybody aware of it beeing a common problem on the vivaro van.It's a 53 plate 1.9 diesel. cheers
  5. S

    Hi Jimmy..I'm from the Wirral...work's terrible around here..I applied for Eon weeks ago..never...

    Hi Jimmy..I'm from the Wirral...work's terrible around here..I applied for Eon weeks ago..never even got an interview!
  6. S

    Hi Paul I'm steve from the wirral..work's terrible at the moment,I saw your post about...

    Hi Paul I'm steve from the wirral..work's terrible at the moment,I saw your post about liberty..has the job been filled.? cheers
  7. S

    twin pump

    hi fellas I'm replacing a glowworm ultimate which is on a twin pump system.pumps and cylinder are on the 3rd floor programmer and boiler in kitchen..ultimate is pump overrun. which boiler will go in without to much of a wiring nightmare??? AND if the relay is gubbed...where can I get one...
  8. S

    potterton combi 80

    frost stat sorted it thanks picasso!!
  9. S

    potterton combi 80

    anybody help me with this before I lose the will to live,boiler continuously fires with the clock and selector switch turned off...its not the DHW flow switch because the red light isn't on...could it be the control PCB behinh the modulation board???...I've even pulled the leads off but it still...
  10. S

    Hi...RE terms and conditions..my email is steveburns69@gmail.com..thanks for your help!!

    Hi...RE terms and conditions..my email is steveburns69@gmail.com..thanks for your help!!
  11. S

    vivaro 53 plate clutch noise

    your first idea seems logical to me as when the clutch engages the noise stops...is it a big job??
  12. S

    vivaro 53 plate clutch noise

    hi all just wanted a heads up on this b4 I go to a garage..when I put the clutch in...to go into 1st gear there is a loud tapping noise..as I bring the clutch to the bite it goes away and the van seems to drive and change gear fine...only does it when I push the clutch peddle down to engage 1st...
Top