indesit di450 LED Error Code. Lights 1 and 2

24 Oct 2010
Reaction score
United Kingdom
Ok Dishwashers been no problem since I moved into my new house.
However last night it continued its cycle for about 4 hours. Didn't really think anything of it until I came to unload it and it was still going. All the stuff inside was stone cold; and had an odd white dotty finish on it.. almost like it had never got any hot water.

I thought then closed the door again, and it starting making wiring noises; and then next think theres water pouring out of it...

So now I guess its mid program, (selection 3 - eco wash) and every time I close the door it fills up with water, and doesn't drain away. It also makes a very loud buzzing noise, seems to be comming from the inside where the tablet would go?
The 5 LED lights on the top are out, unless I unplug it and re-plug it in in which case all 5 come on briefly, along with the salt indicator.

Theres nothing in the manual about it filling up with water constantly :(

Anyone any ideas what might be up??
I hope someone can help :)

Just to add to this I've had another play around with it tonight and LED 1 and 2 are lit up. Its a 5 LED display...anyone any idea what this means?
Thanks again

Thanks :)
Sponsored Links

It was running on program 2 and stuck in the middle leaving hot messy water inside. First, all 5 LED was off, and P selector did not have any effect.

Tried to plugging off-waiting-trying cycles several times, always the same. Also tried the usual 15 sec "P" hold to reset program without any success.

Then, at last started to quickly turning on/off with the big red button like hell(like an idiot) ca. 3-4 times. The LEDs started to light up in a weird sequence. First all 5 LED came up light, then by every on/off cycle one went down. At this point I started suspecting some hardware failure wither with the control board or the program-selection-unit.(where the LEDs are)

I read an article here about resetting the stuck program from the control board. I gave a try. Removed the cover(this is a integrated one), then removed the upper section (6 screw). The reset button at the back (bottom) of the control board. Tried pushing it for short and for long time, alone and together with powering-on, plugging in and all of these combination, so i think i tried almost all of that. Did not help. More importantly the control board was replaced not that long time ago.(4 months) so i thought that control board should be ok, it must be something else.

The only other electronic unit is the program-selector-unit. I saved the old one from the previous service so, i gave a try to replace that.

There is a attachable cable to connect those two together. I realized some oxidation on pin 2-3 on the cable head on the controller board side. I cleared them.
Then replaced the program-selector unit.

Problem fixed.

I don't know if the oxidation on pin 2-3 (seems to be common as i checked both the old and new panels and cables and both had those green zinc-oxid) was the culprit or the faulty program-selector-unit.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links