1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Potterton Promax 12 SL boiler intermittent

Discussion in 'Plumbing and Central Heating' started by Richard Campbell, 23 Oct 2021.

  1. Richard Campbell

    Richard Campbell

    Joined:
    23 Oct 2021
    Messages:
    9
    Thanks Received:
    0
    Country:
    United Kingdom
    Hi, I’m seeking some advice on a problem that’s occurred with my Potterton Promax 12 SL boiler, the problem is intermittent. It comes on in the morning for a few hours. Then when it’s up to temperature it goes off & won’t come back on till the next day. It doesn’t come on in the evening or for a second time in the same day. Even when I try to manually or advance the central heating boiler through the Siemens RWB29 wall controller or wall thermostat it doesn’t fire up. It shows no lights on the boiler or allows me reset it. I appreciate any advice to resolve this problem.

    many thanks
    Richy
     
  2. Sponsored Links
  3. CBW

    CBW

    Joined:
    26 Sep 2019
    Messages:
    9,044
    Thanks Received:
    2,413
    Location:
    North
    Country:
    United Kingdom
    Sounds like a stuck motorised valve - have you got a 2 port or 3 port valve? If you’re unsure post a photo of your cylinder cupboard.
     
  4. Richard Campbell

    Richard Campbell

    Joined:
    23 Oct 2021
    Messages:
    9
    Thanks Received:
    0
    Country:
    United Kingdom
    Thanks for your swift reply, Chris. Hopefully these photos help. It’s a a 3 way valve.
     

    Attached Files:

    Last edited: 23 Oct 2021
  5. ianmcd

    ianmcd

    Joined:
    15 Aug 2010
    Messages:
    23,486
    Thanks Received:
    9,695
    Location:
    Lanarkshire
    Country:
    United Kingdom
    post pics of your programmer and room thermostat as well please
     
    • Thanks Thanks x 1
  6. Richard Campbell

    Richard Campbell

    Joined:
    23 Oct 2021
    Messages:
    9
    Thanks Received:
    0
    Country:
    United Kingdom
    Here’s a few photos of the controller, which is showing the CH & HW is on. Also the room thermostat & some of the boiler cover & cover off. The controller is on but no lights to the boiler in the garage. Thanks
     

    Attached Files:

  7. CBW

    CBW

    Joined:
    26 Sep 2019
    Messages:
    9,044
    Thanks Received:
    2,413
    Location:
    North
    Country:
    United Kingdom
    Turn off the power to the programmer by the fused connection unit switch, leave 5 minutes and turn it back on, see if it kicks in then.
     
  8. Richard Campbell

    Richard Campbell

    Joined:
    23 Oct 2021
    Messages:
    9
    Thanks Received:
    0
    Country:
    United Kingdom
    Thanks, I’ve turned the power off to the controller & it’s powered down. I’ll give that 5 minutes.
     
  9. CBW

    CBW

    Joined:
    26 Sep 2019
    Messages:
    9,044
    Thanks Received:
    2,413
    Location:
    North
    Country:
    United Kingdom
    Whilst it’s off, have a look at the 3 port valve, it should go from H to W.
     
  10. Sponsored Links
  11. Richard Campbell

    Richard Campbell

    Joined:
    23 Oct 2021
    Messages:
    9
    Thanks Received:
    0
    Country:
    United Kingdom
    I’ve turned the power back onto the controller after 5 minutes & no improvement. No power to the boiler. When I turned the power off the 3 way valve went to Water-W & when I switched it back on it returned to Heating-H.
     
  12. Richard Campbell

    Richard Campbell

    Joined:
    23 Oct 2021
    Messages:
    9
    Thanks Received:
    0
    Country:
    United Kingdom
    Thanks for the advice, that’s done the trick. 5 minutes after turning the power back on the boiler fired up. I’ve tested it on the thermostat, manually & automatically on the controller. Thank you very much for your swift advice, guys. It’s done the trick.
     
  13. CBW

    CBW

    Joined:
    26 Sep 2019
    Messages:
    9,044
    Thanks Received:
    2,413
    Location:
    North
    Country:
    United Kingdom
    It’s done the trick for now, but will likely fail again.
     
  14. Richard Campbell

    Richard Campbell

    Joined:
    23 Oct 2021
    Messages:
    9
    Thanks Received:
    0
    Country:
    United Kingdom
    I appreciate I’ve only temporarily solved the symptoms & not necessarily the cause. What’s your advice on a permanent fix?
     
  15. CBW

    CBW

    Joined:
    26 Sep 2019
    Messages:
    9,044
    Thanks Received:
    2,413
    Location:
    North
    Country:
    United Kingdom
    Sounds like it could be the 3 port, which if it is, I’d recommend a new head.
     
  16. Richard Campbell

    Richard Campbell

    Joined:
    23 Oct 2021
    Messages:
    9
    Thanks Received:
    0
    Country:
    United Kingdom
    So change the mid position actuator out?
     

    Attached Files:

  17. CBW

    CBW

    Joined:
    26 Sep 2019
    Messages:
    9,044
    Thanks Received:
    2,413
    Location:
    North
    Country:
    United Kingdom
    Sounds the likely culprit, although one of the more experienced pro’s might say otherwise.
     
Loading...

Share This Page