1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Youtube stopped working "JavaScript turned off"

Discussion in 'Software' started by JohnD, 12 Oct 2007.

  1. JohnD

    JohnD

    Joined:
    15 Nov 2005
    Messages:
    63,014
    Thanks Received:
    3,332
    Location:
    Whale Island
    Country:
    Cook Islands
    Yesterday it startd to give error message "Hello, you either have JavaScript turned off or an old version of Adobe's Flash Player"

    However I had not changed anything and have not consciously turned off Javascript.

    I downloaded the new Flash player successfully, but still get the same message.

    I've had a look in Tools, internet options, Advanced

    Under Java (sun) It has "Use JRE 1.6.0_02 for <applet> (requires restart)" Ticked

    Under Microsoft VM it has
    "Java Console Enables" - Not ticked
    "Java Logging Enabled" - Not ticked
    "JIT combiler for virtual mavhine enabled" Ticked

    In Security
    "Active Scripting" is ticked at "Enable"
    "Scripting of Java Applets" is ticked at Enable
    (which is what Youtube "Help" suggests as the fix)

    Rather oddly, cookies are showig as "blocked" even though the setting for youtube is "always allow"

    What might be the trouble?
     
  2. Diyisfun

    Diyisfun

    Joined:
    15 Jun 2004
    Messages:
    7,185
    Thanks Received:
    278
    Location:
    Norwich
    Country:
    United Kingdom
    Try doing a restore
     
  3. JohnD

    JohnD

    Joined:
    15 Nov 2005
    Messages:
    63,014
    Thanks Received:
    3,332
    Location:
    Whale Island
    Country:
    Cook Islands
    There are no system restore points.

    don't know why - it isn't turned off

    I have since found out that I can see Flash filmettes that aren't from Youtube.

    I have uninstalled Flash and reinstalled it new from Adobe. Still no good.
     
  4. breezer

    breezer

    Joined:
    3 Jan 2003
    Messages:
    23,324
    Thanks Received:
    30
    Location:
    Sussex
    Country:
    United Kingdom
    dont worry about it.

    i have the same problem, only solution i have is down load the latest version of jave, then imeadiatly click the film you want to watch.

    odd / daft thing is, if you go some where else on the www, come back to same page, i have to download it again.
     
  5. JohnD

    JohnD

    Joined:
    15 Nov 2005
    Messages:
    63,014
    Thanks Received:
    3,332
    Location:
    Whale Island
    Country:
    Cook Islands
    don't know... where do I get a new Java?
     
  6. JohnD

    JohnD

    Joined:
    15 Nov 2005
    Messages:
    63,014
    Thanks Received:
    3,332
    Location:
    Whale Island
    Country:
    Cook Islands
    downloaded new Java, and new Flash, still doesn't work :(
     
  7. Sponsored Links
  8. marshman

    marshman

    Joined:
    5 Aug 2007
    Messages:
    550
    Thanks Received:
    30
    Country:
    United Kingdom
  9. JohnD

    JohnD

    Joined:
    15 Nov 2005
    Messages:
    63,014
    Thanks Received:
    3,332
    Location:
    Whale Island
    Country:
    Cook Islands
    grrrrrr

    they suggest installing a standalone version of Flish.

    so I uninstalled Flesh again, and dowloaded the full version, closed all my windows, ran the installer, restarted...

    guess what :mad:

    per the Softwarepatch advice

    I checked the version no's and they both say 9.0.47.0

    which appears to be the latest version

    "Version: 9,0,47,0
    Date Posted: 7/10/2007 " says Adobe download centre latest version.
     
  10. JohnD

    JohnD

    Joined:
    15 Nov 2005
    Messages:
    63,014
    Thanks Received:
    3,332
    Location:
    Whale Island
    Country:
    Cook Islands
    :mad: :mad: :mad:
    I just removed all Java, restarted, downloaded a new one from Sun...

    no improvement.

    just floundering now.
     
  11. empip

    empip

    Joined:
    24 Sep 2005
    Messages:
    6,192
    Thanks Received:
    151
    Country:
    United Kingdom
    Internet properties.

    Security. (internet)
    Download signed activeX controls (enable)
    Run activeX controls marked safe for scripting. (enable)


    Privacy.
    Advanced.
    Overide auto cookie handling (ticked)
    Accept 1st party.
    Always allow session.
    Prompt for 3rd party.
    --------------------------------------------------------
    Recently updated Java is 1.6.0_03 that is 03 not 02.
    Remove previous Java installs via Control Panel, why doesn't the latest install ever remove the old one?
    --------------------------------------------------------
    Firewall setting for YTube site.
    Allow both session and persistent cookies.
    Ads allowed.
    No blocking of JS, Vbs, Java, ActiveX or mime type objects.
    --------------------------------------------------------
    Did the Flash update to 9.0.47.0 when the update including plug-ins became available (did not uninstall previous version) See next post !
    =====================
    Apart from the activeX stuff, To what extent the above settings are affecting my YTube experience I do not know.

    Generally using Opera browser, recently (week or so) noticed 'the error' warning flashing up occasionally in YTube (not for every vid), any video nevertheless, just loads up, and continues to run normally without any action on my part... As if the message did not exist.

    --- So working more or less ok here (IE7,FF2,Opera9), with above settings.
     
  12. empip

    empip

    Joined:
    24 Sep 2005
    Messages:
    6,192
    Thanks Received:
    151
    Country:
    United Kingdom
    Start again... I decided to unload the flash shebang and beat it !

    I want YTube in Opera : FireFox2 : IE7
    Close browsers, ensure all usage of flash has ceased follow the instructions at - How to uninstall the Adobe Flash Player plug-in and ActiveX control Here (Adobe)

    We do understand that Opera and FF (etc) have their own 'plug-in' download?? Here Depending which browser you are using that address gets the relevant download/install page !! No activeX to concern us there, the job is quick and easy ... I downloaded the installer to desktop (I am on BBand but the download was at 14 KB/sec very slow **), ensured firewall settings would allow prog installation... ran the installer, a neat little box described where the plug-ins were installed... Looking good.
    Reboot, test Opera and FF2 - YouTube works quite flawlessly.

    Now I try using IE7 - I guess YTube will not work as I have seen no activeX installation warning... I get no selected video, just the message 'Hello, blah blah'. I am guessing there must be another installation for IE.
    Shut down IE7, Reopen and retried YT - same message, after a while I am taken to an online installation page for Flash... I tried this, again no real idea that anything was happening, I turn off the 'pop up blocker' in IE7... clicked for install again, this time there was action, a pop up warned of an ActiveX install, I ok'ed that, after a while the normal allow/disallow option box for activeX install popped up, ok'ed this, then have the thin horizontal bar with chasing green stripes, for a longish while (** above)... Suddenly a little video played and flash announced it was installed.
    I close IE7. Reboot PC, test YouTube - A ok!! Job done.

    Internet Explorer ActiveX settings - some Adobe words, some my own.
    To change your security level:
    Open Internet Explorer.
    Choose Tools > Internet Options.
    Select the Security tab.
    Choose Internet.
    Click Custom Level.
    Ensure that the Download Signed ActiveX Controls option is set to Prompt. my setting was 'Enabled'
    Ensure that the Run ActiveX Controls And Plug-ins option is set to Prompt. again my setting was 'Enabled'

    Switch off that IE browser's pop-up blocker for the installation. Tools : Pop-up Blocker : Turn off Pop-up Blocker... Or one could set www.youtube.com as an 'allowed' site second option pop-up context menu.

    I needed to set my Firewall to allow downloads, pop-ups, installs and program changes otherwise the activeX install was a no-no... I guess I pretty much turned it off - for the install.

    :cool:
     
  13. JohnD

    JohnD

    Joined:
    15 Nov 2005
    Messages:
    63,014
    Thanks Received:
    3,332
    Location:
    Whale Island
    Country:
    Cook Islands
    fixed it by deleting the cookies.
     
Sponsored Links
Loading...

Share This Page