ferroli 77ff combi problem please help

Discussion in 'Plumbing and Central Heating' started by skippster76, 9 Jul 2005.

  1. skippster76

    Joined:
    9 Jul 2005
    Messages:
    240
    Thanks Received:
    26
    Location:
    Birmingham
    Country:
    United Kingdom
    Hi i have a problem with my ferroli 77ff gas combi. The problem started lastnight.The pilot is alight but when the hot water is turned on the fan kicks in but the main boiler does not ignite,same as if you switch it to heating/water on constant on the selector switch.I have also noticed that the fan blades that you can see have hit a tube and broke off but i dont think this is the main problem.If anyone can help it would be much appreciated. jim.
     
  2. B.O.B DOLE

    Joined:
    16 May 2005
    Messages:
    1,036
    Thanks Received:
    0
    Country:
    United Kingdom
    if this tube is connected to the aps and it is cut the boiler wont fire up
     
  3. skippster76

    Joined:
    9 Jul 2005
    Messages:
    240
    Thanks Received:
    26
    Location:
    Birmingham
    Country:
    United Kingdom
    Hi i have checked the tube and its all intact with no splits.have a new fan assembly on order.
     
  4. B.O.B DOLE

    Joined:
    16 May 2005
    Messages:
    1,036
    Thanks Received:
    0
    Country:
    United Kingdom
    sounds like the gas valve not opening is there voltage to the gas valve

    have also noticed that the fan blades that you can see have hit a tube and broke off

    whats broke off the blades?
     
  5. skippster76

    Joined:
    9 Jul 2005
    Messages:
    240
    Thanks Received:
    26
    Location:
    Birmingham
    Country:
    United Kingdom
    Hi checked for voltage at the microswitch combination gas valve.no voltage found.put voltage to valve, boiler ignites ok.So where do i look now.
     
  6. ollski

    Joined:
    8 Oct 2003
    Messages:
    5,000
    Thanks Received:
    77
    Location:
    Birmingham
    Country:
    United Kingdom
    if you've knocked a tube of the air pressure switch then it wont get past the fan stage...put it back on where it came from and whizz it up again.
     
  7. skippster76

    Joined:
    9 Jul 2005
    Messages:
    240
    Thanks Received:
    26
    Location:
    Birmingham
    Country:
    United Kingdom
    Hi where does the power feed for the gas valve come from,Does it come from the main board if so do i need to replace it?
     
  8. ollski

    Joined:
    8 Oct 2003
    Messages:
    5,000
    Thanks Received:
    77
    Location:
    Birmingham
    Country:
    United Kingdom
    You're starting to sound dangerous now...just put the tube back on or if it is broken get it replaced. nothing will work if the air pressure switch cannot detect the fan operating through this tube. Got a digi camera?
     
  9. skippster76

    Joined:
    9 Jul 2005
    Messages:
    240
    Thanks Received:
    26
    Location:
    Birmingham
    Country:
    United Kingdom
    Right the fan is fine the tube is fine ,the problem is that there is no power feed to the gas valve,i just wanted to know were the feed originates from and if that was the main board would i have to replace the board or is there something else causing it to loose the power feed.many thanks.jim.
     
  10. corgigazza

    Joined:
    29 Dec 2004
    Messages:
    1,799
    Thanks Received:
    311
    Location:
    Bedfordshire
    Country:
    United Kingdom
    Some things that my cause this fault Unable to check instructions as do not have copy.

    manual over heat reset button located on the flow out of the main heat exchanger (push in red button to reset),
    flow switch,
    pump not working
    lack of system water pressure
    faulty thermistor
    APS faulty/hoses round wrong way
    Recommmend corgi engineer
     
  11. ollski

    Joined:
    8 Oct 2003
    Messages:
    5,000
    Thanks Received:
    77
    Location:
    Birmingham
    Country:
    United Kingdom
    best to start at the beginning and work forwards than the end and then backwards, so with that in mind your fan obviously starts does that switch the voltage across on the air pressure switch?
     
  12. skippster76

    Joined:
    9 Jul 2005
    Messages:
    240
    Thanks Received:
    26
    Location:
    Birmingham
    Country:
    United Kingdom
    Checked voltage at air switch found 25volts when i switch system on and fan cuts in.
     
  13. ollski

    Joined:
    8 Oct 2003
    Messages:
    5,000
    Thanks Received:
    77
    Location:
    Birmingham
    Country:
    United Kingdom
    let me have a think about it, but just a quick note to say not to go around sticking a 240v supply onto things like the gas valve...most of this boiler including the gas valve works on 24v and it won't appreciate the extra kick.
     
  14. skippster76

    Joined:
    9 Jul 2005
    Messages:
    240
    Thanks Received:
    26
    Location:
    Birmingham
    Country:
    United Kingdom
    Dont worry mate im quite compitant with most things its just i have'nt tackled a boiler before so be for i started i got my self a basic wiring diagram.i dont try to fix anything without a little investigation first.
     
  15. ollski

    Joined:
    8 Oct 2003
    Messages:
    5,000
    Thanks Received:
    77
    Location:
    Birmingham
    Country:
    United Kingdom
    ok skip no problem it will be the pcb if you have a lit pilot, 24v at the aps and no voltage to the gas valve.
     

Share This Page