1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Devireg 500 underfloor heating not working

Discussion in 'Electrics UK' started by roo roo, 21 Jul 2018.

  1. roo roo

    roo roo

    Joined:
    21 Jul 2018
    Messages:
    3
    Thanks Received:
    0
    Country:
    United Kingdom
    Hi, I have attached a pic of the display. Pressing the button it twisting either way does nothing. Haven't used it ever and it was installed in the bathroom about 10 years ago.
     

    Attached Files:

  2. Sponsored Links
  3. Taylortwocities

    Taylortwocities

    Joined:
    28 Jul 2006
    Messages:
    20,531
    Thanks Received:
    2,132
    Location:
    Oxfordshire
    Country:
    United Kingdom
    Your picture shows the stat with a display showing. Does this display disappear if you turn off the power?

    What do you get when the power is restored?
     
  4. roo roo

    roo roo

    Joined:
    21 Jul 2018
    Messages:
    3
    Thanks Received:
    0
    Country:
    United Kingdom
    Hi, it stays on whether the power is on or off. I'm not quite sure why though.
     
  5. Taylortwocities

    Taylortwocities

    Joined:
    28 Jul 2006
    Messages:
    20,531
    Thanks Received:
    2,132
    Location:
    Oxfordshire
    Country:
    United Kingdom
    It’s printed on the screen then.
    Do you have a voltage test device? Not a neon screwdriver!
    Your next step is to check if mains voltage is actually getting to the stat. Have you checked the fuse?e
     
  6. Sponsored Links
  7. ban-all-sheds

    ban-all-sheds

    Joined:
    27 Aug 2003
    Messages:
    69,782
    Thanks Received:
    2,858
    Location:
    London
    Country:
    United Kingdom
    It'll be a bit tricky to get the installer back if it never worked.

    Why do you want to use it now, after 10 years?
     
    • Thanks Thanks x 1
  8. roo roo

    roo roo

    Joined:
    21 Jul 2018
    Messages:
    3
    Thanks Received:
    0
    Country:
    United Kingdom
    We thought we would put it on to see if it works. I remember the installers tested it when the fitted it at the time of the new bathroom so it did work.

    I wasn't home last night so will check the fuse today.
     
  9. ban-all-sheds

    ban-all-sheds

    Joined:
    27 Aug 2003
    Messages:
    69,782
    Thanks Received:
    2,858
    Location:
    London
    Country:
    United Kingdom
    S'pose it's possible that it's just too warm for it to come on.
     
    • Thanks Thanks x 1
  10. Taylortwocities

    Taylortwocities

    Joined:
    28 Jul 2006
    Messages:
    20,531
    Thanks Received:
    2,132
    Location:
    Oxfordshire
    Country:
    United Kingdom
    I suppose not.
    There is much more to the display when the stat is powered up. My suspicionis that the fuse has popped, or the stat has died, or it may just need a reset.
    In its powered up state, it should look like this:

    Screenshot 2018-07-22 16.56.39.png
     
    • Thanks Thanks x 2
  11. DIYnot Local

    DIYnot Local

    Joined:
    3 Sep 2019
    Country:
    United Kingdom

    If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

    Select the supplier or trade you require, enter your location to begin your search.


    Are you a trade or supplier? You can create your listing free at DIYnot Local

     
Loading...

Share This Page