Honeywell ST9420C and DT92E troubles

29 Oct 2008
Reaction score
United Kingdom

I have had this system working fine for about 3 years with a Worcester 30CDi Classic boiler but over the past 4 or 5 months my DT92E thermostat LCD display blanks off sometimes when I go to adjust settings :/

So, I bought another DT92E received it today and am trying to pair it to the programmer. The ST9420C programmer is in binding mode but refuses to SYNC with the DT92E.

Ok, I thought I'd just rebind the old unit once again. Its having none of it. I don't really want to have to shell out for another ST9420C programmer as well but is this likely to be the issue (I am leaning towards this even though it was working fine right up until I tried the pairing/binding process).

Am I missing something obvious here?


Small update: The binding never shows completed but when I try to rebind each time the programmer shows 'bnd' indicating a device is already attached! The programmer is reset of all bindings I might add and the original and new DT92E is also cleared.
Last edited:
Sponsored Links

Yes, the model is definitely a DT92E. Cleared the factory binding? I have cleared existing by holding down the OK button on the programmer for 8 seconds until display said "RESET" as per the Honeywell instructions. Page 19 on pdf.
Is that classed as the factory binding?
If not, how might I go about this please? Any info I can read up on?

Sponsored Links
Any info I can read up on?

How about starting with the manual that came with the DT92E, specifically the section called "Binding/Rebinding Procedure" which tells you how to clear the existing binding in the DT92E? You need to clear both that and the programmer binding before you start a new binding procedure

Yes, Ive done that and received the CLR message on the DT92E. I read the original DT92E may need to be cleared as well so did the CLR on that unit too, this is the problem. I cant rebind either unit after following the manual instructions which is what's led me here. Both DT92E's were removed fine but stuck at rebinding. I have never had an issue with receiving /transmitting signals from the programmer or original DT92E, the binding was done at factory. Its only now that there is an issue. Both units do flash a wifi symbol at times on the LoT display they just wont bind. The ST9420C flashes - - - - waiting for the signal from the DT92E when set to COnt and after pressing the power button. (Done after going through the Inst menu to Clr first).

The procedure has been carried out over and over but am stuck at rebinding.

Thank you
Still cant sort this. Just tried it again.
Cleared binding on ST9420C to start with then, scrolled through and checked Control ands Sensors had - - - - (nothing bound, ok so far), selected Sensor Heating and pressed OK, this starting the Binding process with flashing - - - - (so far so good). Over to DT92E, cleared binding first then put screen back to Ctrl and pressed ok. I could see on the ST9420C that the wifi symbol flashed when I pressed the ok button on the DT92E (indicating to me that something was being sent/received). That's where it goes pear shaped, no sync message or complete message. So,. I cancel the binding on the ST9420C and scroll through Control and Sensor setting only to find the Sensor for Heating now shows Bnd in the display. I clear this out and go through the above procedure again with same result. :confused:

I'm going to borrow my mates ST9420C and DT92E from an unused Sundial RF Pack 3 kit which should be fine as it'll come prebound at least.
Last edited:
I did think of that until I saw the BDR91 requires mains wiring to get power, not much effort really but I'd still have to sort the cabling. My current setup is the Sundial RF Pack 2 so it never used the BDR91.
Cant try the Sundial RF Pack 3 kit after all, the DT92E was sold out of the box last year I'm told.
Looking into Hive installs now!
Final Update: This morning I attempted the binding again using my original DT92E and it worked first time. Then unbound it, tried the new DT92E (which wasn't brand new I might add) and nothing. Went back to original and worked first time again so maybe the DT92E I just bought has a duff wireless signal even though it does appear to send out a signal according to symbol on the display when power button is pressed.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links